mLink 2 Installation Error


I used to be able to install mlink2 on my system (Windows 10 Enterprise, version 22H2, build 19045.3930) and connect to arduino uno boards plugged in to my USB port when using the browser-based ide.

However, since this morning, whenever I click connect, the ide prompts me to download and install mlink2. When I try to reinstall the software, it the installation process hangs after <10s, with the message “Installation aborted”. mlink2_install%20error.

Turning off Windows security makes no difference - I get the same error message. I used to see mlink2 in task manager but that has also disappeared.

Any suggestions on how to resolve this would be appreciated. Thanks.


@skeatz Contact support:
Re-download mLink:
And remember that mLink only needs installed once.
This may be a new version conflict. I’ll report it.

Good luck!


Thanks, @Best_codes. I have tried downloading a fresh copy of mlink2 from the site, same issue. At the moment, I’m not sure if it is an mlink2 problem or my Windows problem. Other software, such as desktop version of mblock runs fine.

I’ll try contact as well and see if they are able to help.


:slight_smile: OK, let me know what makeblock support says. Typical response time is 1–2 days, but can be 5 or more. Good luck @skeatz!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.