mDraw does not display image svg


when I start mDraw and open a BMP image, I can’t convert it to SVG.
If instead I convert to SVG via InkScape, when I open the SVG image, the program closes. Use mDraw ver.1.2. My makeblock XY kit has only the servo and not the laser.
all this happens on a laptop that has: windows 10 home 64 bit, 32Gb RAM, nvidia geforce GTX, intel core i7 8th gen.
Thanks for the attention


Hi olimpio2004,
Will you show me a screen shot or video?
And may I have the file so I can test in my side?
XY plotter upgraded version contains a laser.


the file .SVG is attached. If I try to insert it with a BMP extension, when I click on “convert to SVG” (with at least 0.75 treash hold%), nothing happens. Months ago, with another computer, I had no problem.
Thanks for the reply. (435.9 KB)


I tried with your picture, cannot open it in mDraw.
I test some pictures, I can convert to svg. Please have a try. I sent to your email box.


thanks for the test files. I’ve tried them now and they work well. why can’t i do the same with my files? I’ve tried in every way, but every time, the software, don’t convert the BMP to SVG.


if I open the attached SVG file, mDraw closes. The version I’m using is 1.2.1. (31.2 KB)


problem solved. the error of not creating SVG from BMP (using mDraw 1.2) is because the BMP destination folder is on the desktop. I solved by moving the BMP / SVG workbook to C: BMP (the name I used for the folder is random). It’s very important to create BMP files with dimensions no larger than 20x20cm
thanks a lot to Stefanie Wu (




This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.