MCreate print not printing files


Hi guys,

I purchased the MCreate 3D printer through our local supplier last week and have nothing but a hassle trying to get it to print.

I installed Ultimaker Cura 5.2.1 then install the Cura plug-in 0.5.0 downloaded from the website. It installed ok on both the Win10 PC and my Mac. I followed the video instructions exactly. The Makeblock MCreate print was in the list of printers and I was able to select it.

I tried a few of my STL files. The model loads fine and it performed the slice as expected. I then loaded the gCode file onto a USB stick. I then inserted the stick into the printer, selected it to print. I looked fine and comes up saying “Print Progressing 0%” and that’s it, it never goes past 0%. This occurs regardless of whether I use the Mac or the PC. Same result. I also tried the version of Cura that is provided on the USB stick with the printer, but same result.

I noticed that the are some files on the USB stick that came with the printer. I tried these and they print fine, but I notice that they are a lbx format and not gz. They come up on the printer showing an icon image of the print whereas the gz files just show a gcode icon and not an image.

I have sent the Makeblock support people an email but I’ve not heard anything back.

Very frustrating. Has anyone encountered this or can suggest what the issue could be?



Have you tried putting an STL file on the USB stick?


I haven’t tried that, I’ll see if that works. Will the printer itself then do the slicing needed? As a BTW, I found that it does printer if I select to print directly to the printer via the USB cable. It just won’t do it if I use the USB key. The GZ file is there and comes up, but when selected and go to print it from the printer is just sits there saying 0% progress and the head nor the base show as heating.


An update on your suggestion. Tried it but the printer doesn’t show the stl file, only the gcode files.


So it works with the USB cable?


Yes, it works if I use a USB cable. But if I same the gcode file to a usb flashdrive then it just shows Progressing 0%. I’ve tried 2 different flash drives, same result.
But good that at least I can now print.


BTW, I heard back from their support people. They want firmware and software versions and a video of the issue, so will do that today and see what they say.


Hmm… :confused:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.