mBot2 Shield mBuild port issue?


I just bought and assembled the mBot2 with the SmartWorld AddOn recently.

When I connect servos to the mBot2 Shield, they work perfectly.

When I connect any sensor (I tried with the ultrasonic sensor and the Quad RGB sensor) to the mBuild port on the mBot2 Shield, it does NOT work, I tried with an example program given on the site it gives zero output, the lights do not turn on, nothing; however as soon as I connect any/all of the sensors to the mBuild port on the CyberPi it works great. I can actually see the distances in the ultrasonic sensor.

What could the issue be?


Could you define “mBot 2 shield”? Is this part of the mBot or the cyberpi device?


mbot2 shield is the adapter for the CyberPi. Anyways the issue was figured out. I tried the same configuration with the port on the CyberPi itself and this worked. Eventually the really great, I have to say, Makeblock support figured out that one of the pins of the port wasn’t working. It was a hardware issue. They will send a replacement.


Great! I’m glad it’s solved!


Thanks @Best_codes!


No problem! :smile:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.