Mbot2 Firmware update


#1

Hi all,

Just became the proud owner of a Mbot2 version (Model MCP-K04-02). Now I am trying to update the firmware version through the Mblock desktop (v5.3.0)

Steps taken:

  1. I added Mbot from the library
  2. I tried a direct USB connection from my laptop (Windows) however it does not find the Mbot
  3. I connect from my Laptop (Windows) through Bluetooth and that works, I can also connect from my Ipad which works as well
  4. Than when I choose the highlighted update it indicates that it cannot perform the update
  5. I think I need this update to actually start using the mBlock v3.5.0. package.

What can I do? Any help much appreciated.

Kind regards,
Erwin


#2

Hi Erwin, I made a simple tutorial for you on the mBot Neo update, please follow the steps and try again. Make sure that the switch of the mBot Neo is switched to ON, also the CyberPi is well connected with the car:


image
image

Hope this could help you.


#3

Hi Support,

Thank you so much for your quick reply! I seem to be making progress. However the update stops when it reaches 20%. The CyperPI is well connected to the chassis! My software and drivers are up to date.

When I check the USB connection:

I checked the USB in my device manager and basically it says it can not connect to this USB:

26/5/2021
When I reinstalled Mblock software I noticed the following:
afbeelding
This USB driver did not install. Please advice, is this driver required? Where can I download it?
Greetins, Erwin


#4

Hi Erwin, did you switch the mBot 2 to ON position? If you did, try to update it via the website mBlock 5 with mLink 2 in Google Chrome: https://ide.makeblock.com


#5

Hi,

This worked! Thanks a million :wink:

Kind regards,
Erwin