MBot2 and iPad


Good morning,

We have brought 10 m:Bot 2’s for our Junior students. Our Junior students use iPads. We are using the mBlock app. We can connect the robot to the iPad very easily. We get the confimration sound that the robot is connected everytime. That’s great. However, we cannot flash the code across to the robot and run it. The only way it seems we can run code is to run the code live from the iPad. When we press the green flag to run the code on the MBot, nothing happens. We have the lastest updates on the iPad and also have updated the firmware on the MBot. Do you have any suggestions? The robot works if we code on a laptop. However, running the app on a laptop or computer is not an option as we brought these robots under the understanding we can code it through an iPad.

Thank you.


Are you using live or upload mode? Also, what code are you trying?


Thank you for your response. We are using live. It’s the only option that works on the iPad. Here is the code.


Try some other blocks, e.g., with the mBot’s lights or something. This will help determine if the issue is with hardware or software.


Thanks for your quick response. I’ve tried that. Still no luck. All 10 of the robots fail to work. The same code work when I use it on a laptop.

Does anyone know if MBot2’s work with iPads? Can anyone confirm?

Sadly, we may have to move to using laptops; which is not suitable for primary school, but this may be the only way we can get a return on our investment and use these devices.


It should… Have you gone to the app permissions and made sure that app has all the permissions it needs? Also, does your iPad use BLE (Blue Tooth Low Energy)?


I have got a Mbot Ranger to work with a iPad.

+1 on that.

+1 on that too.

The robots turn on properly?


@V205 @drm917k Do you have any photo of how the mBot’s motors are connected to the mBot?


Not sure why I was pinged but here is the proper connection for the motors:



Oops! Sorry, that was an accident. Thanks for your post, though. :smile: Although I believe he is working with an mBot, not Neo, currently.