MBot won't connect to iOS bluetooth, blue light flashing


#1

I have 4 brand new Duracell batteries and I have two Bluetooth modules (one came with MBot) and I ordered another at same time - both are BLE V1.0_c. I turn MBot on the bluetooth module light comes on steady. I’ve downloaded MakeBlock and mBlocky three different times on my iPhone. Each time I attempt to connect to my MBot with iPhone over bluetooth from either app - the phone searches for the MBot and shows up as connected under Settings-Bluetooth - but on the MBot the central blue light (next to the red power light) starts blinking and neither app ever connects.

I’ve seen similar posts that date back over several years and I haven’t found a useful solution. Please provide some useful troubleshooting tips. My MBot is only three days old. MBot V1.1 Bluetooth version.


#2

Sorry, I misspoke. When mBot is powered up the bluetooth module’s blue light flashes. As soon as my iPhone app MakeBlock or mBlockBlocky starts searching for the mBot - the bluetooth module’s light goes steady and the central blue light starts blinking. This happens regardless of which of my two bluetooth modules I have attached to the mCore.

Please help.


#3

One potential issue is if multiple devices are paired with the mBot. Try to turn on Bluetooth only on the device which you are currently using.


#4

Andreas,

Please explain this more. I only have one mBot and one iPhone that I’m trying to connect by bluetooth. I have my laptop turned off so it isn’t trying to connect to the mBot.

Tonight, I tried connecting with mBlockBlocky. As soon as I hit the connect button on my iPhone screen - the mBot’s tiny blue light next to the red power light starts flashing and the mBot doesn’t respond to any of the mBlockBlocky tasks. However, mBlockBlocky shows it has connected by bluetooth with the mBot.

I have no other phones or bluetooth devices within 15 feet of the mBot when I’m trying to connect with it.

What else can I try?

Thanks


#5

Here is the opposite scenario, with my iPhone turned off, I can connect my mBot via MakeBlock to my laptop by bluetooth. However, as soon as I try to run any actions - the exact same problem occurs. The mBot’s blue light in the middle of the mCore starts flashing and it won’t respond to any code.

Again, it is showing connected by bluetooth, but it won’t play sounds, move, or change any lights - only the blue light starts blinking.

Batteries are new, have only been turned on less than one hour total.


#6

Ok, next thing to try is to update your firmware. Connect your mBot to the PC using the USB cable for that.
https://www.mblock.cc/doc/en/faq/firmware.html


#7

Andreas,

I’ve already updated firmware three times - this didn’t change anything.

Why is blue light in middle of mCore flashing every time the mBot connects to my computer or iPhone by bluetooth as soon as I attempt to run line of code in MakeBlock?

Andreas, I appreciate your help - how many mBots have you worked on? How did you start working with mBots?


#8

I have 6 mBots here and run workshops with them every month, using iOs, Android, Windows 10, and MacOs.
Windows 10 Bluetooth connection to mBot is shaky, unless you use the Bluetooth dongle. All the other systems work pretty stable here.
Maybe there is a hardware issue with your mBot, now that we have sorted out the most common other causes.