Mbot v 1.1 STEM won't connect to bluetooth on Windows 10


#1

I need some help connecting Mbot v1.1(bluetooth version, makeblock 90053) to the bluetooth on laptop- Windows 10. I have followed instructions from Guide for using Bluetooth 4.0 on a Windows PC - FAQs | mBlock

Guide for using Bluetooth 4.0 on a Windows PC - FAQs | mBlock
If you are to use mBlock 5 on a Windows PC equipped with a non-Bluetooth 4.0 protocol, you need to use a Bluetoo…

but my problem with bluetooth connectivity couldn’t be resolved, as bluetooth adapter on my laptop is version 6. something and not bluetooth 4.0.

Also, I have updated the firmware for mblock and still no effect. I hope you can help me, so my 9 year old son can use his birthday gift to its full potential. Thank you.

Here are details of my laptops’ bluetooth adapter: Realtek bluetooth adapter - firmware 10. 55691/LMP 10.241
As I mentioned a version of updated firmware from mblock is 016.01.007 that I’ve downloaded but still nothing happened.


#2

we had 2 kinds of Bluetooth version for mBot,one is have Bluetooth 4.0(New version) in mBot,another one is 2.4G module(old version) in mBot.

If your mBot is Bluetooth 4.0,but still cannot connect with your PC after followed the Guide,then you need a Bluetooth dongle accordingly.here is the image for Bluetooth 4.0,you can check it in your mBot

If your mBot is 2.4G module,you need to use the white adaptor which should be together with your mBot while you bought it.


#3

Hi @tech_support, we are having a similiar problem here and haven’t been able to connect mBot to a Windows PC all year. We can connect no problem to the apps on both the iPhone and iPad but cannot connect to Windows 10. I have tried connecting with USB cable, with bluetooth and with 2.4G module and dongle but none of them are working. I have Bluetooth 4+ on my laptop - do I need to replace the mCore? mBot is about two years old now but my daughter hasn’t been able to play with the extension kit in a whole year as we cannot connect… thanks in advance for any help


#4

Hello Alaoisec,

To help tech_support, can you provide some additional information?

For your inquiry, I don’t believe you will need to replace the mCore. Probably the iPhone and iPad app would not work, if there was a serious problem.

The tech_support will probably solve your problem which must be with the drivers.

Michel


#5

@tech_support and @Crackel

Thanks so much for your help.
So last week I had been able to connect via bluetooth only on MBlock 3, but couldn’t use it as was told I needed to upgrade the firmware however then connecting via USB cable or 2.4G module and cable didn’t work. Then I downloaded mBlock 5 and now I can’t connect at all via any of my three options. I also downloaded mLink 2 and have tried using both cloud and local mBlock and nothing will work.

If it is a driver issue, would you be able to point me in the right direction so I can update the driver? Again thank you so so much!


#6

I am not an expert but I will see this page: here


#7

@Crackel @tech_support

Crackel you are a genius thank you so much - we now have a driver installed and are connected via USB cable!!

Only of course this leads me to the next issue, the firmware upgrade fails at 4% each time…
We have tried connecting both to mBlock 5 on the laptop (windows 10) and also by starting mLink2 and connecting to the online app. In both scenarios, we connect via USB cable successfully, get a notice to say upgrade firmware, choose online firmware and the installation fails at 4%. I have also tried removing the bluetooth module from mBot for this process but it doesn’t seem to make a difference… Any pointers please?


#8

Hello Alaoisec,

Right now I’m going to take a guess and Makeblock maybe laugh at me. To the left of the USB, there is a button: Reset which is difficult to reach. Press it while turning on the mBot and now for a few seconds to finally release the button. Try again for Firmware …

It’s rubbish, but while waiting for the experts at Makeblock, we risk nothing to try. It won’t break anything.


#9

@Crackel @tech_support

Crackel thank you so much for your help so far, unfortunately the reset trick didn’t work for me and the firmware still fails at 4%.

Any other suggestions and I will happily try as I am not sure what to do next…

Thank you


#10

Hi alaoisec,

Call me back if you have tried LIVE mode to verify that the mBot understands the instructions?
Live

Try a few easy things …
Loop


#11

So we are connecting in LIVE mode alright however the “when mBot(mcore) starts up” command is greyed out and if I type something simple like When green flag pressed, light up LED, it will show as if the code is running (yellow highlight outline around the code) however nothing happens on mBot…


#12

Ok, if it’s yellow then it’s well connected. Makeblock need to look at this with you.

Sorry, I leave my place to the PRO


#13

well thank you @Crackel for all your support - you have been amazing and very generous with your time

@tech_support any suggestions please?