mBot Ranger Not Working



I have come across a problem recently in which my robot fails to properly function. It doesn’t carry out any of its basic functions, and when I turn it on it doesn’t have the multiple blinking lights as it had before, but rather a green light.

It won’t move or connect through Bluetooth on the 2 MakeBlock Apps, but it does receive codes from a USB, although it won’t carry out any of the coded material. My robotics teachers suggested I reconnect everything, push any cables in farther if they haven’t been pushed enough, change the batteries, etc… But everything they suggested hasn’t worked. I have also worked on three different devices within the last four days so I could see if these problems persisted and if they could be fixed, but there was always the same outcome. I have also updated the firmware and that didn’t improve the situation as well.


Hi Jasminem,

We have received your email and replied you with the suggestions.
Please check the power of the robot according to the email. Thanks!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.