Mbot Ranger, no bluetooth detected


I have an MBot ranger, but no phone or tablet I have tried it with can detect it via Bluetooth, even though these phones and tablet have no problems detecting and pairing with other blue tooth devices.

Phones tried include two different Samsung Galaxy S9s (Android), and my Galaxy Tab S2 Android tablet.

My PC is pretty new and has Bluetooth version 5, but also cannot detect the ranger

Despite what the troubleshooting steps I have read suggest, the Bluetooth module does not ever have any blue led glowing at all.

I have tried and successfully updated firmware via USB connection to PC, but no change

I have tried removing and reseating the bluetooth module, but no change.

I have tried pushing the small black button on the front of the module - no change (what is this button for? I guessed it might be to activate pairing mode, but it does not seem to do anything)

What do I do now?


Hi Paul,

Sorry to hear about the issue.
We have received your email reporting with the same issue and provide suggestion to you.
Please check and let us know.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.