mBot Ranger motors no longer working


I ordered an mBot Ranger robot a few weeks ago, and it’s my very first robot.

I had already used some Ranger and Starter Kit at school, and I bought mine for my end of year project. First I did the Land Raider, then the Nervous Bird, and they all worked perfectly. Then, two days ago, I wanted to do the Dashing Raptor. Once finished, I turned it on, connected it to my phone via bluetooth with the Makeblock application, as I had done several times before.
Except that the wheels started spinning backwards very quickly, then stopped when I lifted the Ranger. Since then, I couldn’t get the motors to work again.
I reinstalled the firmware several times, using Arduino, but it doesn’t change anything. I can make sound and lights using the application, but I can’t make the motors work.
I’ve already looked for solutions on this forum, and I’ve seen that the problem could come from the batteries, not providing enough power. So I bought new AA 1.5V batteries, but it didn’t change anything.
I dismantled the robot, so that only the motors, batteries, and Me Auriga were left, I also removed the wheels to see if the motors were not turning too slowly to make the wheels turn.
I changed the encoder motor wires, in case I damaged them.
Despite all this, I still haven’t been able to get the motors working again.
I’ve tried to give as much detail as possible.
Thank you in advance for your help.


This might seem like a silly question, but are you connecting it via USB, if so are you also switching on the power button on the unit? If you plug it into the USB, it may LOOK like it’s powered on, but that only powers the circuit board, it does not switch on the battery power to the motors. When you battery power is on, you should see a green LED illuminate beside port 1.


Yes, I connect it via USB, but only for uploading programs. When I use it, I unplug it and its only source of electricity are the batteries. And yes, the green LED marked POWER is on.
By the way, the two red and blue LEDs next to the bluetooth module also light up when I try to start the engines with the Makeblock application, which shows that the connection between my phone and the robot is working, and that the Auriga ME is receiving the information.



  1. basıt bir uygulama yap motor dönmesi için.yükle.
    2.sök-tak tüm parçaların oturduğuna amin ol.
  2. motorların dönmesi kesin olduğu için bir ölçü aleti (avometre) ile motorları kablolarını ölç kaç volt .okuyorsun.sonuç bir deger varsa motor sıkışmış takılmış tekerleri kontrol et her hangi bir voltaj yoksa.1.motor sürücüsü yanmış olabilir.2. motor sürücüsüne .çıkış sinyal gelmiyor. bunuda bir ölçü aleti ile yapmalısın …
    bir kaç resim olsa daha iyi olurdu.


Thank you for your answer, unfortunately I don’t speak Turkish (language identified when I write your answer in Google Translate). I will therefore answer you assuming that Google Translate has not made any translation errors, and I apologize if my answers are not correct.

You say that the rotation of the engines is certain, but it’s just not, the engines don’t work anymore.
And unfortunately I don’t have an avometer, only my school has one, and with the covid-19 crisis right now, I don’t have access to it.


yeah wrong translation.(I wish you health first).

If there is no 1.avometer, the solution is difficult without taking measurements.
try these ways.
Step 1: Install simple program for mbot engine (look engines have temperature?).
the engine is hot but does not turn.
engine hot engine wheel stuck. mechanical control.

Step 3 If the motor is not hot, the motor socket and motor drive are faulty. can.
3. What is the motor driver. a simple rolee.?
a few pictures engine and driver. sorry for english


Hi, I’m sorry it took so long to anwer you.

I’ve been looking for programs to measure engine temperature, I couldn’t find any.
But the engines are not blocked since I can turn the wheels by hand without encountering any resistance.

(on the pictures, the ME Auriga is not fixed to the structure but all the connections are made correctly)



It is really hard to help when I am not physically there.

So it seems you have ruled out that the motor are physically jammed as you can turn them by hand.

This leaves that the motors are not receiving power or the motor are dead, I find it super highly unlikely that both motors will die at exactly then same time so I suspect that they are not receiving power.

The first thing that I would try is to power the motors via external power source i.e unplug them from the ranger and use a power source to the leads going to the motor and see if the motors turn. Here’s the pin out and you can see the yellow pins marked M1+, M1- and M2+, M2- are the motor pins that supply power from the ranger to the motors.

If the motor turn then you have now look at why the ranger board doesn’t turn the motors. If the green power light is coming on then that tells me power is getting from the batteries to the ranger. It is possible that the H-bridge on your ranger has died and I would hook up my oscilloscope to the output pins on the ranger to see what is coming out of the ranger but I assume you don’t have a scope.



Hi TangWhite,
As I have replyed you in the email.
Please upload the program I attached to your robot and test.
When running the code please observe if there are two blue led come on beside M1 & M2, I have marked the leds, you can see it from the picture below.

Take a video for me if possible.


Hello there,

While I was asking you for help, I was also in contact with the support team. I am happy to tell you that my mBlock Ranger robot is fixed.

Following the support’s advice, I reinstalled the firmware, but using mBlock5 instead of Arduino, and it worked. The motors are working again. I feel a bit stupid not to have thought about using another software, but I was sure the firmware was correctly installed, since I could turn on the LEDs and make sounds with the makeblock application, only the engines were not working.

I still don’t know where I went wrong in my use of Arduino, but thank you for helping me.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.