mBot Ranger Bluetooth not Connecting


Just built the mbot ranger and it will not connect using Bluetooth. I have tried several devices. Everything is updated. Any other suggestions?


Make sure that the chip is plugged into the board:

and the device / app has Bluetooth permission:
For computers, see
For phones and tablets, see
and make sure your device is supported.

@Ashleysyd If you can give me some more info about your OS, the device (phone / tablet / PC), and the version of the app you are using I can help you more. Thanks!


The board is inside the box that was already pre built. I have tried iPhone 12 Pro using ios 17.1.2.
Using the mBlock app and makeblock app. Also tried a ipad 10 generation using ios 17.1.2. Same apps
On MacBook Pro I am using mBlock v5.4.3
MacOS Monterey 12.72-12.41gb


Just took the top off and the Bluetooth board is connected. Still not working


I’ve also noticed there are 3 red lights flashing rapidly. One by the eyes, the middle and near the blue tooth.


When using a PC, please test with version 5.4.0 or 5.3.0.

What type of Bluetooth connection are you attempting on PC? For PCs, use the Bluetooth dongle:

A flashing Bluetooth light means that the robot isn’t connected.

Make sure that all the apps have Bluetooth permission. Do you have more info or screenshots of what you are doing?



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.