mBot Ranger: Bluetooth keeps disconnecting


#1

My new mBot Ranger keeps disconnecting when coupled to the Makeblock app (Android) via Bluetooth. This happens every time I use the whirl button in the app or when the bot slowly bumps into something or drives across a small hindrance. I think it is related to a faulty bluetooth module. Or is there another way to cure this issue?


#2

@Tristratos
Did you return your bot and did the bluetooth disconnection problem you mentioned persist even with a new bot?


#3

Have you tried using the Bluetooth dongle with a PC to see if the problem is the app or the electronic device?


#4

@Best_codes
I have already tried with my Android tablet - same issue.


#5

Try a PC. (A desktop computer).Use mBlock 5.4 on that.


#6

(1) I replaced the Alkaline batteries by Nimh rechargeable batteries and experience less bluetooth disconnections, e.g. whirl works now without bluetooth disconnecting. Still, bluetooth disconnections keep happening quite regularly. You should definitely recommend only dry batteries in the manual, not alkaline ones if you know that your hardware (bluetooth) does not work properly with those under electrical load.
(2) Using mblock 5 would not help, since it is a hardware issue…
(3) By the way, mblock 3 is much clearer and more intuitive than mblock 5 and offers more options through a reasonable menu, so I use mblock 3 instead. Software should in general become better from version to version, mblock 5 unfortunately seems to be a regression in comparision to its predecessor mblock 3. I also think that you should add a documentation to mblock 5, having a message stating “Documentation is under way” gives a bad impression of the software.
(5) However, I will keep my bot, because it is in general quite cool; please keep improving hardware and software though, it would be a much better experience. Thanks


#7

Vieleicht hat das Modul auch einen Wackler?!


#8

Ja, aber wenn ich den Me Auriga öffne, um das Bluetooth-Modul fester einzustecken, erlischt möglicherweise die Garantie…


#9

Hmm… :confused:

I see your 4 (?) observations…
Have you tried a PC or mBlock online to see if the issue is actually the hardware?


#10

Den Me Auriga? Was ist das?

Sorry

ich bin noch nicht solange hier drinnen.

#11

So heißt das Modul.


#12

Achso