Mbot Ranger and blue tooth controller


I have an mBot Ranger and also a makeblock bluetooth controller. . From the makeblock website I downloaded the sample program “Official BTC for Ranger”.

After I uploaded to the mBot ranger, the program worked perfectly as long as the ranger was still connect to my PC via USB cable. If I disconnect the USB cable, the buttons to control motion do not work correctly. If I push the ‘forward’ button, instead of moving forward smoothly, it moves forward for a second, stops for a second, moves forward for a second, etc. Same thing for reverse, left turn, and right turn.

I do not understand why being connected to my PC with a USB cable would make the program work different, but that is what happens.


Hello Chapan, according to your description, I think the problem should be the battery. The high performance motors on Ranger consume large amount of power, and after several minutes of using, the voltage of the batteries is low and not enough to motive the motors. When you connect Ranger via USB cable, there’s external power source and that’s why it worked with USB connected. Please try to use ALL brand new batteries when not connecting via USB. Mix of new and used batteries couldn’t provide enough voltage as well. Please have a try.


That was it. Thanks for the quick response.


Hello, I also am trying to connect the make block Bluetooth controller to the ranger but I need the “Official BTC for Ranger” or “Official BTC for mBot-mblock.rar” program and it is not available on the make block website or anywhere.

Please upload it here so I can use the controller with the ranger.

Please advise.


Please provide a link to download the “Official BTC for mBot-mblock.rar” program.

Thank you