Mbot (older model?) not updating


I have an mbot that is a couple years old. Recently I tried to boot it up but upon starting a firmware update, it gets to 3% and then replays the startup tune and the update stops. I am on a USB connection and I have the 2.4g model. Ok was about to post this when I fixed it so I thought I would say how. I took off the Bluetooth module from the motherboard and that seemed to fix the issue. Hope you guys can use this?


Hi MbotNoWorkPlsHelp,
Please try to update firmware via USB connection.
To update firmware for mBot, please install mBlock5 to your computer, you can download from here.

After you have installed the software, please following the steps to update firmware for your robot.
1)Connect your robot to the computer with USB cable, open the software and click connect.
2)After connected, go to setting and you will get the option to update firmware.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.