mBot not responding to IR remote after upgrade to 06.01.107


I used mBlock v5.3.0 on a Windows 10 PC to upgrade firmware from 06.01.007 to 06.01.107.

Now the mBot does not respond to the IR remote. None of Manual Mode, Automatic Obstacle-avoidance Mode nor Line-following mode work.

The remote has a new battery and I tested its function via the camera in an Android phone and it works.

An additional thing is that the “Button” on the mBot no longer functions.

The mBot works with the Android Makeblock App version 3.5.1 in all “Play” options except “Draw and Run”. It does not follow the path drawn and seems to do random movements.

I tried the reset button but that did not solve the issue.

Any help would be welcome. Can I revert to the earlier firmware which does respond to the IR remote?

I have just answered my last question. Although my “Factory” firmware was 06.01.007 mBlock offered “Factory” version 06.01.009 so I downgraded from 06.01.107 to 009 and the mBot now responds to the IR remote. However “Draw and Run” does not follow the path and does random movements.


Hi NormC,

Everything is normal. IR works with Factory Firmware, but not with Online Factory. For the “Draw and Run”, I believe it is a feature of the Codey Rocky and not of the mBot. You must change the device in the application to select the mBot.


G’day Crackel,
Thank you for your prompt reply.
In the Android App when I select mBot and Play I get the option for “Draw and Run” but it doesn’t work. I just downloaded the iOS app and the same erratic behaviour occurs with it. I would have thought that if “Draw and Run” only worked for Codey Rocky that it would not be offered as an option for Play in mBot.
You said “not with Online Factory” but version 009, that I downloaded and installed, was the online factory version and that resolved the issue of the mBot not working at all.
I am only a beginner so it is all a new world for me! Thanks again.


Hi NormC,

We are talking about the Makerblock application on tablets ???


  • To play
  • Coded
  • To build
  • Create
  • Develop

Codey rocky

  • Drive
  • Draw and execute
  • Coded

For the 2 Firmwares … they are functional but they probably have differences like version 6.01.009 is for the default behavior with IR. The other version is without code. I’m not sure but to program my things, I use version 06.01.107


G’day Crackel,

Sorry for my lack of information on the platforms I am attempting to use.

I have Makeblock app on an Android mobile phone (Google 4XL running Android version 11 with the Dec 5, 2020 update) and I have Makeblock on a, now dated, iPad running iOS 10.3.4. I have also been trying out the Android App mBlock Blockly on the phone. On my Windows 10 PC I have mBlock v5.3.0.

You have resolved my question on why firmware 06.01.107 didn’t work for me, i.e. no code, so thanks.

I ran the iPad Makeblock App, selected Codey Rocky and connected and it ignored my selection and recognised it was an mBot. I think I have come to the realisation that the Draw and Run option in Play option is not a very good implementation, unless of course there is some sort of “user error”!

Thanks for your assistance, I will play with it some more and might even try to do some programming. It’s a long time since I have done that!


No problem … If you need help … don’t hesitate …


I’m a newbie with mblock:mbot, and I’ve tried the different firmware versions, and I found some quirkiness between the firmware, and hopefully, this will help someone out there.
The two versions are Online firmware(06.01.107), and Factory firmware(06.01.009).
The Default Programs, that is, using the IR remote to control manually (using A), obstacle avoidance (B), and line-follow © ONLY works for Factory firmware.
But if you have custom programs that try to sense the IR remote buttons, then you need Online firmware (but then you lose the Default Programs, which I think it’s tolerable, because you want to play with the robot, right?)
I had tested it using 2.4G connection.
I haven’t tested uploading the custom program to the mbot yet. I’ll do further report after I have done that.


I have just done the upload, and it responds to the IR remote OK.

My conclusion:
Since you are developing your own custom programs to run on the mbot, you might as well stuck with Online firmware version 06.01.107.

Only if you really want to run those default programs, then update to Factory firmware, and forego the IR remote control, which I think you lost a big chunk of the control of the robot.


Hi cccl,

This is good logic, your reasoning is fine. Now have fun and if you need any help just come back to the forum.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.