mBot not connecting to mBlock v5.4.0 (PC on Windows 10) via USB


Hi there,
I face problem to connect mBot Ranger to mBlock v5.4.0 running on my PC on Windows 10 home edition via USB. In my case COM7 is offered correctly, but when connecting, error “Connecting error. Please try to connect again” appears.


last available driver CH341SER.INF, version 3.5 2019.1 was also installed.

I reinstalled mBlock several times - without success. Any idea how to solve this?Thank you


Hi there:

Please follow the steps of 020 to solve this problem


thank you for your advise - but unfortunatelly even when following steps of 020, problem persists.
I checked all 3 steps under 020:

step 1:


step 2:
latest driver CH340 is installed

step 3:
correct WIN10 patch is also installed.

After computer restart problem of connection is unfortunatelly still the same
Any other idea?
Thank you



How about checking your USB port and USB cable that you are using? it might have some issues.



I also checked USB ports - I tried all ports on my PC with the same result. Also tried another USB cable without success…



If your machine doesn’t exceed the warranty we suggest contact with local distributor or seller to fix this problem


Hi Pavel

Just a thought - try turning off anything else connected to your PC via USB, particularly a printer (I have to do this) & then start mBlock - hope this helps.



You can follow the same steps of 018 troubleshooting to check the mainboard of mBot to make sure it works normally and if you still can’t figure out the problem you can send it back to our retailer




This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.