mBot + mBlock 5 on Chromebook upload not working


#1

Please help. Just bought 14 mBots. 1 per student for coding in this new Covid-19 environment. Each student has a chromebook at their disposal. Was hoping it was a perfect solution. Here is my problem:

Finished the build today and connected the mbot to Chromebook via usb. Installed the mlink extension and was able to connect to the mbot through the ide.mblock.com interface. I made a short program:
When mbot(mcore) starts up
move forward at power 50% for 1 sec

Switched to upload mode. Tried to upload and the upload fails telling me to check the logic in my program.

Switched to LIVE mode and changed the starting event to “when onboard button is pressed” and the robot follows the program perfectly.

Tethered robots will NOT work for class. PLEASE HELP!

I updated firmware to 06.01.107
I’ve also downgraded to factory (06.01.009) and tried the above with the same results.


#2

Hello Sardog,

Sorry about the delayed reply.

In order to solve your problem, can you tell me that is it only occurs on one mBot or other mBots as well?

Also, have you tried this on a Windows PC or Mac? If not, please have a try and let us know the result.

Also, for timely reply, please reply me and copy to my email dare.mao@makeblock.com , thanks!

Best Regards
Dare