mBot IR receiver does not work


I just bought my first 2.4 GHz mBot and got everything to work (including line following), except for the IR remote. I tried uploading firmware and the resetting default program, which I managed to do succesfully, but turned out not to be a solution. I used new batteries in the remote, exchanged them for others, tested with a camera phone and could see the IR light… but still no luck. I am on Mac OS High Sierra.

My only guess left is that I was unlucky to get a faulty mBot. Any other ideas? And what should I do if it is indeed faulty?


Hi rmeijerink,

When you reset the mBot by updating the firmware in mBlock on PC.
You also have to update the firmware for IR because otherwise the remote will not work. The mBot also makes another music.

Me, that was my problem. I sometimes forget to put the IR firmware.


Thanks. How do you separately reset the firmware for IR?



I do not have the application

In the software mBlock 4.0.4 under PC, there is 2 sub menu in Update Firmware (USB).


I was using V3.4.11, will give V4.0.4 a try!


Found the option for separately updating the IR remote you were talking about; unfortunately, that does not help. Any other suggestions?


Does the update work?
Did the mBot make a little music?


Hi rmeijerink,

When you keep press a button on IR controller, can you always see a solid (or quick flash) red light? If yes, normally the IR remote controller works.

Here I explain the difference between mBlock 4.0.4 and mBlock 3.4.11
The mBlock 4.0.4 is experimental version, to make the mBot works with IR controller, need choose the option “update the firmware for IR”.
The mBlock 3.4.11 is official version, to make mBot works with IR controller, need choose the option “Reset Default Porgram”-> “mBot” (not upgrade firmware).

For the problem, may I know do you choose the correct serial port (similar to /dev/tty.wchusbserial1410.) and correct Board (mBot -mCore) while Upgrade firmware for IR?
If yes, as Crackel mentioned, is there a little music (with the RGB LED switch different colors) after successfully uploaded the program?


I do NOT see a red light on the mBot when pressing a button on the remote. (Assuming you are not talking about the red PWR-led, which is on, or the red light on the ultrasonic sensor, which is on as well.) Where should that light be located?

I tried both v4.0.4 (upgrading firmware for mBot and remote) and v3.4.11 (upgrading firmware and resetting default program). No luck. I made sure to choose the correct serial port and board, so the upgrading/uploading is successful, and I see the changing lights and hear the “music”.


Hi rmeijerink,

Sorry for the confusion.
I mean when you test the IR remote controller with the Camera on Android phone. Can you always see a solid (or quick flash) red light from the android phone camera if keep pressing a button on IR controller?8. How to judge if my IR remote controller is ok.docx.zip (10.9 KB)

Besides, since you can see the changing lights and hear the music, that means the default program has uploaded successfully. In this case, please try press a green button on the mBot to switch its working modes.
Normally, the two RGB LEDs will change color each time you press the green button.
When the RGB LEDs lit up white, it is in manual mode.
When the RGB LEDs lit up green, it is in object avoidance mode. Please check if the mBot keep moves until it meets object in front, then turn its direction.
When the RGB LEDs lit up blue, it is in line follower mode. Please check if mBot moves along the line follower map.
If mBot moves properly in last two modes, we think the robot works. We can locate the issue is on IR controller or IR transmitter sensor on the mCore.
If mBot doesn’t move a bit, we suspect if the battery can provide enough power to the mBot. In this case, please change the battery have a check.
According to our test and research, it is suggested to use rechargeable Li-ion battery or rechargeable nickel-metal hydride, nickel-cadmium which can be bought from amazon or local shop. Or Alkaline battery with good quality like Energizer, DURACELL.



The other two working modes work, so the mBot moves and switching between modes is not a problem.

Agreed. How do we go from here?


Hi rmeijerink,

From your description, the IR controller should be okay.
Do you mean there is totally no response on mBot when you press button on IR controller?
Could you try again to press the button A/B/C on the IR controller and check if the two RGB LEDs switch the color too?

If totally no response, we suspect the issue is on IR receiver on the mCore board. In this case, may we know where did you buy it? If it was bought from re seller, you can contact the re seller for the warranty of one mCore board.
If it was bought from makeblock official store, please send the receipt to email address daisy@makeblock.com.


I finally managed to fix the problem. I had tested the remote IR light (with a camera phone), but noticed that the light from a TV remote that was lying around was much brighter. I had already replaced the battery with a new (!) one from the same battery package, which had not helped. I bought a new packet of batteries and that fixed the problem.

So sorry to have asked for help, when the solution was that easy. Thanks a lot, Crackel and tec_support!


Hi rmeijerink,

Glad to hear that it fixed!