MBot initially worked but now flashes error an hour later


#1

Just set up our first mBot today in advance of a project with a Scouts group in three days.

Initially it worked great - it was able to immediately move and adjust its direction in response to objects immediately ahead.

I then tried to program some simple code with mBlockly. The Bluetooth connection to our iPad worked fine. I could change the led light colour and make sounds. But as soon as I tried to make the mBot move via code, the two main LEDs turned red and a small blue light right beside USB port 1 began to flicker randomly and after a few seconds it sounded like a car blinker was on.

After turning the mBot off and waiting for a minute, I was able to turn it back on and have it boot successfully and perform other tasks but not move.

Later, I tried increasing the power allocated to the movement above the default 100 in my code and the mBot actually moved. But shortly thereafter that stopped working as well, no matter how much power I assigned.

Now, I must leave the mBot off for a long time for it to boot successfully, and even then it quickly reverts to the aforementioned error mode even before I send it any commands.

Given the progressive nature of the problem I am tempted to conclude it is a battery issue? Reluctant to put 4 more batteries in to test it if they will be eaten by the mBot after 2-3 minutes of total usage.

Could it be that the wheels are somehow misaligned and this is consuming vast amounts of power? I will admit it was hard to get the screw in perfectly aligned, but I think I did an OK job. Furthermore the mBot was happily moving in the default mode initially.

Reluctant to do the firmware upgrade that everyone on the forum seems to suggest for most problems since it worked successfully for a while and I do not have easy access to a PC that will work with the mBot. We bought this because it functions with iPads.

Must teach to children in three days!

Thanks for any help


#2

Hello elasc,
It seems that mBot lacks enough power.
May I ask what kind of battery you used?
How long it worked normally and then got the issue like yours? One hour of new battery?


#3

The Aa battery type is Kirkland, a name made by Duracell. The four batteries were new.

I only got perhaps 5 minutes of use of the mBot while it was turned on. Of that, perhaps 1 minute of movement.


#4

That is strange. Have you ever tried to reset default program for the mBot in PC software?
Try another brand battery? Or try some rechargeable battery?
Would you also please take a video for us to show the issue? You may send it to stephanie.wu@makeblock.com via https://transfer.pcloud.com/


#5

After leaving the robot untouched for two days, I removed the batteries and tested them. They were still full. I then reinserted them into the mBot and everything worked perfectly. Very curious. Perhaps a battery wasn’t touching quite right beforehand, though they all looked fine and originally it had worked.

In any event, fingers crossed the problem does not recur and thank you for your assistance.


#6

Well, I am not quite sure the cause either. :joy:
Anytime any issue happen to it, please just contact us.