mBot bluetooth connection Windows 10 and Ble


#1

Hi all,

I know there are lots of threads about connecting the mBot to the pc via Bluetooth but 2 days in and I still cant’t get it to work. What I tried so far:

  • Installed mBlock5
  • connected mBot via usb cable
  • updated online firmware
  • disconnected mBot
  • restart both mBot and mBlock5
  • I have bluetooth enabled on my laptop (I don’t use any kind of dongle)
  • try to connect through bluetooth using mBlock5

What happens is that it keeps searching forever for devices but never finds my mBot

Variation I tried:

  • using mBlock3
  • uploading an empty sketch/reset default program
  • tried a different laptop with no luck
  • connect with makeblock_lexxxxxxx through windows 10 devices

Am I doing something wrong or can anyone help me?
Is the makeblock_le the correct module?
Are there other ways of connecting through bluetooth instead of using mBlock?

Bluetooth chip of my laptop: Qualcomm Atheros AR3012 Bluetooth 4.0
Firmware version: HCI 6.25 / LMP 6.1

When I try to connect the mBot with my Android phone it instantly works

bluetooth_adapter


mBot Ranger Bluetooth Connection?
#2

Hello Atonbom, frankly speaking, the Bluetooth function for mBot is basically only made for mobile devices, and we don’t recommend our users to connect mBot to computers via Bluetooth. Due to that there are different Bluetooth modules and protocols for the Bluetooth module on different computers, we cannot support all. So usually we don’t suggest our users to connect mBot to computer via Bluetooth. If you really want to connect computer with mBot wirelessly, you can use a Makeblock Bluetooth dongle. If you want to know more about the Bluetooth connection, you can check this link for more details: https://www.mblock.cc/doc/en/faq/bluetooth.html Note that this is a very old link and it may not be suitable for your PC.


#3

Okay. Thx for your reply. The link you send is also something I already tried but didn’t work. I will consider the dongle or otherwise maybe a Raspberry Pi to connect with mBot via USB.

It’s just a little disappoioting that this isn’t more clear when you buy the device. But anyway I’ll figure something out.


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.