mBot 2 Servos


I have the smartworld expansion, which has a build for a grabbing arm. I have a code where it should actuate the servo motors, but they don’t move. I made sure that the code was getting to that point by saying “light up red/yellow” right before the servo code. I have rechecked my wiring, and tried the following code types for sevo driver and smart servo:
servo driver [1] sets angle to 90
servo driver [1] increases angle by 20
Has anyone else ran into this issue?


@bcrcstaff What device and extension are you using in the mBlock editor?


I am using the cyberpi device and I have added the mBot 2 chassis, mBot2 extension, and the servo driver extensions. i have also tried the smart servo extension.


Do you have any other code besides what you shared? Can you copy the C code, so I can see how it looks?
It sounds like a wiring problem to me, but you said you checked your wiring. If you’ve got a lot of time, you can contact support (the response might take a while) via email:
Good luck!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.