mBlock upload to Codey from iPad? Help!



I’ve been trying out the iPad version of mBlock and am impressed with the way the code executes live on the iPad. The only problem with this is that if the Bluetooth connection drops out, Codey-Rocky runs away and crashes into whatever it was heading toward.

How do I upload my code to Codey from the iPad version? I’m using version 0.8.0.



How was the Bluetooth connection? How often? Distance? Enough power? Tested with other device, same issue?

Obstacle avoiding, you have programmed by yourself? How was the program? By the way, when and where did you purchase it?

For mBlock App, there is no way to upload program to Codey Rocky. If you use Makeblock App, you can do that. But before using Makeblock App, you need to upgrade firmware in mBlock 5-RC to Makeblock App compatible firmware like below:


I’m not sure why the Bluetooth connection was dropping out. Both devices were fully charged and close to each other yet the link would drop out after 2 to 5 minutes. Codey happily stays connected to a Makeblock Bluetooth dongle when it’s plugged into my laptop, my iPad works fine with Bluetooth speakers and Apple Pencil.

The obstacle avoidance program was one that I wrote with my son. It works fine when I upload it to Codey from my laptop.

I obtained Codey-Rocky by backing the Kickstarter campaign.

Thanks for letting me know the feature isn’t there in mBlock for iPad, I was pulling my hair out trying to find it!

I updated Codey’s firmware, and tried the Makeblock app. Drive and Draw and Run work nicely (and I’m not getting Bluetooth dropouts). Code seems to work on the iPad, Codey flashes blue to show it has received the code, but the code doesn’t run. Not even a basic ‘hello world’ runs.

I’m not sure what’s going on there.


The disconnection issue is quite strange, I never encountered before. Will you have more tests?

The codes do not run when using Makeblock App coding and uploading, have you confirm that currently the firmware version of Codey is 006.004? In mBlock 5, we need select that firmware and update. In Makeblock App, we can check its version. If it still doesn’t run the code, will you send me the codes, I will have a test.



I finally had a chance to have another play with Codey-Rocky.

The mBlock Bluetooth dropout issue seems to have gone away. I ran Codey-Rocky for 30 minutes without dropouts. The program execution pauses (sending Codey-Rocky on a crash trajectory) when the iPad’s screen saver cuts in, but resumes when I unlock the iPad. The Bluetooth connection remains solid.

Makeblock works fine in Drive and Draw and Run modes, but Code mode doesn’t work at all. Codey seems to receive the uploaded code, the little blue light flashes, but is otherwise unresponsive. Even for a very simple ‘hello world’:

when Codey starts up
play sound hello

Codey’s firmware is at, and I re-flashed him just to be sure.



Hello peters,
Glad to hear that Bluetooth connection is good now.
For the other question, if you want to use Makeblock App to control and program for the Codey Rocky, please update firmware to, which can be done in PC mBlock 5 (currently it is V5.0.1) and select this firmware:
After that, everything will be working fine in Makeblock App.


Same issue here. I updated my iOS with TunesKit iOS System Recovery, now it works well.


@vincentyyl @peters It looks like this may actually be an iOS or app permissions issue. Report the bug to makeblock via email at