Mblock talkative pet software issue


HI. I have purchased recently an expansion pack for my son Mbot. Is called talkative pet. We have assemblied it and tried to upload the firmware. Everithing looks ok like the SD card has all the voices, the plugs and everithing connects well however after downloading the pack from makeblock site I was not able to load the program via PC app.

mBlock PC version
Version: V5.2.0

After downloading the software pack from Makeblock site i got a zip file called Talkative-Pet_Case Program.zip and inside I have a file Robot-Dog.sb2. When I try to import this file in the MBlock 5 pc app it loads all the program in the Sprites section of the software. Even after I add the Mbot again and the extension pack (uppon importing the file these are dissapearing from my menu) I cannot shift the program in the Mbot section. I have also downloaded an alternative version of the file from the educational website however I get a lot of errors before compiling and I cannot upload in the mbot.

Can anybody help me with this since I cannot find any step by step tutorial and I find it very difficult to make the pack working.

Thank you.


Hello Tmisulica, due to the programs for the expansion pack were released a looong time ago, the files are designed in mBlock 3 with the format of .sb2, therefore you might need to upload or edit the program by using mBlock 3. However, mBlock 3 is not supported in the latest MacOS. Therefore I’m afraid that you might need a Windows PC to use mBlock 3. Download page: https://mblock.makeblock.com/en-us/download/


Thank you. Finally an response. I have mailed mblock team, posted before and so on. I was on the virge of throwing them away :slight_smile:. Suffering since 6 months.

I will try that. Have a great day

One more question: Is there any way to convert it for mblock 5 ?


Not really. If you really want to use it in mBlock 5, you will have to open both mBlock 3 and mBlock 5 at the same time and then try to make a new(like a copy from mBlock 3 to mBlock 5). Note that some of the blocks are changed in mBlock 5 than what they are in mBlock 3, therefore you will need to find the right blocks and change them to the latest.


Hi friend. I did as suggested, installed mblock 3.4.12 on a different PC, imported the script from the official case website and finally was able to see the program properly. I struggled a little bit until I realized that undefined blocks will stay undefined until I install some extensions like mePlayer and so on.

However was not able to get it working. Tried all different sort of things also checked the script which seems fine with the exception of some blocks written in Chinese ( I assume no problem there).

I tried also to see if a simple program like Mbot program followed by simple command like play a file or move ahead or something, works, and DOES NOT WORK.

I connect fine to the device and I can update the script or revert back to the stock however nothing works, even a simple command.

Any suggestion ?



Hi Tmisulica, in this case, please record a video and send to support@makeblock.com , as well as your program files. We will try to locate the problem and come back to you.


I will do so. Thank you but will I get an answer this time because last time I got no reply on my mail for the same issue.

Also could it be a problem that I updated the firmware as recommended in makeblock 5 version ?

Thank you


It will not be a problem. Please keep the firmware up to date.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.