Mblock 5 Ranger: can't control motors, stuck in auto-balance mode?


#1

Hello, I’m trying to use an mBot Ranger with mblock 5 (using both a PC and a Mac.) I have successfully connected the Ranger to my Mac and I have written simple programs that control the LEDs, make sounds, reads the sensors, etc. However, when I use the “move” blocks, it doesn’t work.

I’ve done some troubleshooting so I’ll share what I know so far.

  1. The problem isn’t power. I’ve tried when connected and powered by USB, and I’ve tried with a plugin power supply that has worked well in the past.

  2. When connected “Live” with USB, no movement blocks do anything. The motors don’t turn. However, when I connect to the Ranger using Bluetooth, the motors move by themselves with no instruction. They seem to be in auto-balance mode as if running the Nervous Bird program. Yet, I can’t stop the movement or do any kind of control with the Movement blocks. I’m assuming I can’t control the motors because it is in auto balance mode.

How do I get the device out of auto balance mode using mblock 5 so I can program the motors to move the way I want them to?


#2

Not sure if this helps but maybe worth knowing that USB doesn’t power the motors, only the batteries can do that due to the current drain, and you need to make sure the power is on even when attached via USB (it looks like it’s powered on, but the motors aren’t).

Not sure what the autobalance thing is all about - perhaps some dodgy code uploaded?


#3

Thanks for the response Murray. I’ve done clean firmware update several times, and I have the power plugged in. When you say that the power looks like it is on, but isn’t, I’m not certain how to be sure then. It is “live connected” to my computer and it is taking commands such as play a note, or flash the LEDs, so I assume that means it is in fact powered on, correct?

But yes, when powered by the batteries or the external power supply, it is in auto-balance mode and will not let me send commands to the motors using the “move” blocks. Am I missing something?


#4

Hi. Sorry but not correct. The LEDs and audio CAN be powered by the USB, but the Encoder motors get their power from the batteries only. Simply plug into USB, then hit the red power button. You should see a green LED illuminate beside port 1, that’s how you know the battery power is on.

Hope that helps. Not sure what’s wrong with the motor driver however. If you load the standard firmware, can you drive it around ok with the mobile app? If not, there sounds like a problem with the driver chip, I’d consider sending it back for repair.


#5

I have the USB and the power supply plugged in. When I turn it on, the wheels run automatically in autobalance mode. I connect with mBlock 5 in “live” mode. The wheels continue to operate in auto-balance mode. From live mode, I can make the LEDs flash, I can make it beep, I can read the sensors, etc, but none of the “action” move blocks have any effect. Presumably because it is still in autobalance mode. Updating the firmware goes fine, but results in the same behavior.

So, how can I get this thing into a state where I can control the motors?


#6

Here’s the thing. If I write an app using “move” blocks and I UPLOAD it instead of trying to run it live, the motors move just fine. But if I connect in “live” mode, it runs in autobalance mode and no motor control commands work.

Is that the way this is supposed to work?


#7

Hi.

No, that’s not how it’s supposed to work. When I connect my ranger in LIVE mode, it behaves the same way as UPLOAD mode on both my Mac and PCs.

The difference between the two modes is that in LIVE mode it uploads standard firmware to the mBot and , and mblock sends commands to the firmware to undertake actions, whereas in UPLOAD mode, the code you write is converted into C software, compiled and uploaded into the mBot, so it runs autonomously.

It sounds as if the standard firmware is somehow corrupt or not working with your Auriga board for some reason and it’s causing the motors to go into some kind of ‘jitter’ mode . I haven’t seen that before.

@tech_support will hopefully come it at some point and offer some advice.


#8

When you upload the firmware in LIVE mode, what is the version? Mine uploads 09.01.017


#9

Hi kdrent,

Please try to switch the mode of the Ranger to manual control mode (go to Drive refer to picture below) through the Makeblock APP.
Then try to control the movement of the ranger in live mode through mBlock 5.
image
Once there is still problem, is it possible to take a video to your operation and the problem? You can send video to email address daisy@makeblock.com via Wetransfer website.


#10

Thank you, that was also my problem.