Line Follower Sensor 1 Defective


#1

Hi,

I need help in my line follower sensor. Sensor 1 is no longer working properly. It cannot detect white lines. I have tried connecting it to other robots and the result is still the same.

Does this mean that the sensor needs already replacement or is there any way to repair the sensor?

Thanks,

Cris


#2

Hi Cris

You should perhaps try connecting your line follower sensor module to a powered-on mBot to see if the little red LED immediately to the left of the RJ25 socket is illuminated. If it does, then the module is active. Next put a finger over the end of the sensors on the underside of the board - if the module is working OK then a little blue LED should illuminate over the top of the covered sensor on the topside of the board. If you can see these, then your module should be working OK… N.B. Both LEDs should be on over a light surface and both off over a dark surface.

The module works when the light energy from the emitting LEDs in the line-following sensor reflects off a surface, information about the reflective properties of that surface is transmitted back to mBot and the lighter the colour of the surface, the more light is reflected (in comparison to the amount of light that is reflected from a dark coloured surface).

Each blue light is a good indicator of what each LED pair can ‘see’. If both LEDs are ON, they indicate that there are high levels of reflected light and are over a light surface - the sensor module returns a value of ‘3’. If both are OFF this indicates low levels of reflected light (they are over a dark surface) and the sensor module returns a value of ‘0’. The sensor uses its LEDs to constantly check the contrast between the surface below each of them - if the left-hand blue-indicator light on top of the module is OFF it shows that low reflected light (a black surface) is detected on the left pair of LEDs and the module will return the number ‘2’. Conversely, if the right-hand blue-indicator light on top of the module is OFF it shows that low reflected light (a black surface) is detected on the right pair of LEDs and the module will return the number ‘1’.

If you connect mBot in ‘Live’ mode and then on the Sensing section of the Blocks Palette tick the checkbox to the left of the line follower sensor block, this will add a feedback block to mBlock’s ‘Stage’ area. You should see 0,1,2 or 3 being returned here as you test the sensor as described above.

If you still get no feedback, check that you have the correct RJ25 port selected. If still nothing after perhaps testing the module on all four ports, you may need to kick the sensor into action by running a simple block script like the one shown below which uses a variable which I created called ‘Light_Value’. Activating this **should** flash mBots LEDs for confirmation of the script running and the sensor feedback should now be seen on the stage.

I hope that this works for you


#3

Thank you so much for your quick response @CommandeR and a very detailed discussion.

I tried this already but no LED light (blue) on sensor 1 when on top of a reflective surface e.g. hand or white paper. Only Sensor 2 changes its state.

Is there any way to repair the board or any work around that you know? I have 3 line follower sensors that have the same issue.

Thanks,

Cris


#4

Hi Cris

Adding clear and full details to all posts is the key to this Forum being successful.

If you do indeed have three sensor modules with the same issue then this suggests something else. Try using another RJ25 connecting cable and test it on all four ports in turn. I think that these modules are very reliable so for three to show the same error …


#5

Here are the captured pictures of the testing that I did. I agree that these sensors are very reliable. We have more than 40 mBots used for our workshops. The other line follower sensors are working fine.

Thank you @CommandeR


#6

Have you tried updating the Factory firmware?


#7

Yep. Maybe there is a defective electronic component in the board.


#8

I meant flashing a fresh load of the latest Factory firmware back into mBot’s onboard eeprom.

Try looking look at Chapter 6 of:
https://education.makeblock.com/resources/res-mbot/56549/


#9

This often happens if the line sensor gets banged on anything. They are very fragile.
You can buy another here:

You can also troubleshoot by trying different cables.
Thanks for your time,
Best_codes


#10

@CommandeR

This is a very nice learning material. I learned a lot from it. I have already tried your suggestions but the same results happened.

I think the sensors are already defective.

Thank you so much.


#11

@Best_codes,

Thank you. I am from Philippines. I’ll just order from our partner school here. Do you have any experience in repairing or replacing some of the electronic components like the Infrared LED or the photodiode then re-solder them in the board?


#12

Glad you found the book useful. Did you re-flash your mBot’s eprom with Factory firmware?


#13

The components on-board like the Infrared LED have wires that go through a hole in the board, so they should be easy to solder. However, components like the photodiode may be surface-mounted, which is hard to do. You might have to find a YouTube tutorial on surface mount soldering if you are planning on replacing some of the surface-mounted components.

Thanks for your time,
Best_codes