Laserbox USB connection issues and Working Interface


I’m hoping some people can help me with the issues I’m experiencing with my brand new Makeblock Laserbox machine. I’ve tried to contact Makeblock via email, but I’m not getting much assistance.

So, I recently received the Laserbox and followed the manual instruction on setting it up, to the letter. After a successful initial set up and trial run, I’m not experiencing the following problems:

  1. The USB connection constantly fails.

My computer is new and the USB ports with my other hardware, including my laser printer, mouse, external hard drives, etc - they all work. But when I plug in the USB for the Laserbox, the connection sound is heard, and then it disconnects. Every time! So the solid white ring on the cutter indicates there is no connection. It worked on the first start and set-up and now I can’t get it to connect properly.

First I thought it might be my anti-virus program, so I allowed the device in my firewall. No change. I then, as an experiment, completely turned off my anti-virus just to see if it made a difference - it didn’t. I swapped USB ports with other hardware, and still, only the Laserbox isn’t connecting properly. I uninstalled the Laserbox program and reinstalled. I turned off the USB’s power management. I uninstalled and re-installed the USB hub. I tried looking for a new Laserbox driver, but ended up on a Makeblock website that wasn’t in English. I’m not sure what else to try?

And just and FYI - I don’t use the Ethernet cable because I only have one port and it’s used for the house network and my Wifi is not the best in my basement office. USB is my best option.

  1. My Working Interface doesn’t match what is in the manual.

Even when this worked on the initial set-up and start up, the downloaded software I got from doesn’t match what is in the manual. The ‘Working’ and ‘Cut’ headings are missing and instead I have a ‘Flat Surface Mode’ heading. Not sure why my Working Interface looks different with the missing headings. Anyone experience this? Does anyone have a link for the standard interface.

I’m a small business owner who dropped big money on this cutter because it was advertised as easy to set-up and use. I have a major convention next weekend and I’m getting frustrated with this machine. Any help or guidance is appreciated. Thank you for your help.


Update - After trial and error, I was able to figure out the USB connection issue.
However, I am still requesting assistance with the differing Working Interfaces.


Bonjour, sur les nouvelles versions, il y a un changement par surface plate car le logiciel peut conduire une autre machine qui a une option de coupe sur matériau rotatif mais cela ne change rien a la finalité, il faut rester sur mode surface plate, il y a les memes fonctionnalités mais a des endroits un peu différents…


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.