Laserbox is not functioning with Error Qx143



I’ve been trying to get an issue sorted with my laserbox for a week now. The machine has a hard error Qx143 and won’t work at all. My reseller in the UK has been helpful but they are finding it difficult to get answers from the European Makeblock supplier called Media Direct. I have lost a weeks work with this problem and I really need to get the machine back up and running. The troubleshooting guide has some suggestions - but none of them have worked for me. Can the moderator of the forum please suggest who I can talk to in order to get the problem fixed.

It seems like this is a hardware fault although upgrading the firmware did get the machine working for about an hour before it broke again and now won’t work at all.

Cheers Stuart


Hi Stuart,

Sorry for the delay since we had three days off for celebrating the dragon boat day and also sorry to hear about the issue.

We will follow on this and communicate with the distributors to solve the problem for you asap.
Just double confirm, could you check if you have check all the points in this troubleshooting since I can’t open the link you shared.
If you have tried all the points, could you kindly let me know the checking result of each point so that I can help judge the final cause and provide solution for you.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.