LaserBox Annular Button does not light up


#1

Just got the LaserBox with rotary adapter a couple of weeks ago and finally getting around to setting it up. After I turn it on the light in the power switch turns on but the LED Button on the top does not light up at all. After a minute or so I do hear a beep, but no lights. Also have attempted to connect with USB a couple of times but that always fails also.

What do I do next?


#2

Hi there

Download and install the latest software from the official website
Download link https://www.makeblock.com/cn/laserbox-specs#software
Firmware update method
The computer needs to be online.
Open the laserbox software
Click the menu bar in the upper left corner, click “Help” in the drop-down menu, and then click “Check for Updates”


#3

Was able to connect using scan network for device. USB does not work.

Download Firmware update ok but installation failed with code Qx060.

Reviewed documentation for this code and tried steps in that procedure.

Rebooted machine and tried firmware update again. Still failed.

Opened Lid to check for light from RGB board. There is no light from above or below.

Looked at cables to control board. The 3 cables seem to be seated well and no visible breaks can be seen.

What next?


#4
  1. Confirm whether to use the official USB data cable;
  2. When installing the software, close all anti-virus software and update the laserbox software and laser box firmware to the latest version. If the current computer cannot connect to the device to update, try to find another computer to connect; if there is no other computer available for connection, try to update with an SD card firmware;
  3. Close all circumvention software (100% cannot connect when the circumvention software is open);
  4. Wait for the machine to turn on. After the 6 ring lights are always white, then connect to the software (if 6 white lights cannot be turned on, it means the machine itself is abnormal), after the connection, there will be a beep, and the 6 ring lights will change. Blue
  5. Insert the USB before turning on the laser box, turn on the laser box, and connect to the host computer;
  6. Use a network cable to connect the device to the computer. If the Apple computer cannot be connected to the USB, you can use a network cable adapter to try to connect or use a windows computer to connect and configure a Wifi connection;
  7. If the above operations cannot be solved, try to install the driver
    Windows driver reference: https://makeblock.yuque.com/mkquality/yyl8ng/nf3xir#UwqZJ
    Mac drive reference accessories;
  8. After the Apple computer is upgraded to the latest system Bigsur, because the SIP protection system is turned on, it cannot be connected. You can manually close the SIP and try to connect again. The closing steps are as follows:
    a.Turn off your Mac (Apple> Shut Down)
    b.Hold down Command-R and press the Power button
    c. Wait for OS X to boot into the OS X Utilities window
    d.Choose Utilities> Terminal
    e.Enter csrutil disable
    f.Enter reboot
    g.Run the command on Terminal: sudo kextload /Library/Extensions/HoRNDIS.kext

#5

And this is the solution for Qx060:



Disassemble the glass panel on the right side of the machine, check whether the wire of the button control panel is loose or broken, and plug and unplug the wire again or change the wire

If the RGB light is not on and the fill light on the right side of the machine is normal, replace the RGB small Board;
If the RGB light and the fill light on the right side of the machine are not on, consider the signal transmission exception of the motherboard, replace the motherboard or the patch cord


#6

I setup a windows system and successfully install the current laserbox software.

I used the USB cable that was shipped with the laserbox and successfully connected to the laserbox.

I performed the firmware update process and successfully downloaded the firmware but the update failed.

As before whenever the laserbox software tries to control the laserbox I get the Qx060 error.

Also, I did notice that the right side LED fill light does not light up. The left side LED fill light is working.

If opening the right side is the next step how do I take off the top plastic panel? No screws are visible.

Thanks


#7

Hi Ben:

Our colleague of DTC department is following up on this problem,please wait patienly and wish you

have a good day.