Laser pointer block fails to charge


#1

I understand that the laser pointer block has a rechargeable battery built in. I tried to charge it by connecting to the wifi block and to the USB port of my computer. It works when connected, but fails when using it standalone. Is the battery faulty?


#2

Hi, can you tell me what the product do you use? I am afraid I am not sure what is the Laser pointer block you mentioned…:worried:


#3

I got hold of a Science Lab Kit, which contains the Laser Pointer Block.


#4

any pictures for me?


#5

I suppose it’s one of the first neuron-kits


#6

Hi albertepp,

I have the same Laser block I received with the KickStarter. It worked very well.

For the past few months, I have had the same problem as you. Battery seems over :sleepy:


#7

Is there a possibility to replace this battery?


#8

Good question for Makeblock.
Wait for the answer.


#9

bump. support?


#10

It seems that they are on leave for Chinese New Year.

We are waiting … you have to be patient.