Issues with mBot and Loading Programs


#1

Greetings All,

I run a small program for youth learning to program the mBot. However, everything was fine last time I ran the camp, however this time when I went to use the mBots this time, we found issues sending the program to the mBot using version 5 of Scratch from your website. I uninstalled version 5 and reinstalled version 3. However, our attempts were frustrated again; the program appeared to download via USB cable to the mBot, but the mBot did not appear to run.

I successfully updated both the firmware and was successful in installing the default program, however once again the program did not appear to run.

Please advise what I am missing? It is very important that I get this fixed so my classes can progress.

Thank you in advance.

Stenvne Thomas.


#2

Hi StenvneT,

Makeblock will probably get back to you quickly, but here are some points to help them help you.

  1. What OS are you using? (Windows, Lunix, Chrome book or MAC)?
  2. Did you install mLink 2 version ???
  3. Update Firmware
    1
  4. Try a little program. Does it works ?
    2

#3

Greetings,

The OS we are using is fully patched Windows 10.

The firmware on the mBot has been updated to what the mBlock Scratch software version 3 says is the latest…

We tried a simple program - When keyboard Letter A go forward, etc… No joy… despite a successful report from download to device.

we did not install the Link software… in fact I had never heard of it… nor was it installed when everything was working… so kind of stumped here.


#4

Hi StenvneT,

You found your problem. The Local version and that you installed on your computer does not need mLink. For the web version, you need an mLink (a gateway).

Here’s the address : mLink

For the small program, I recommend switching to Upload mode because the robot is completely independent. for can also use the joystick. Keyboard Letter A … it’s live mode or otherwise it’s complex. I await your feedback because with Windows, you will not have a real problem.
3

Conclusion:

Web = mLink
Local = Nothing


#5

Greetings,

We were using the locally installed version 3, on the Windows 10 O/S. We were not using the Web Version. If I understand your question then mLink would not seem to be required. The program is right out of their teaching guide where you program the robot to respond to keyboard strokes to enact movements on the mBot.

Cheers,

Stenvne.


#6

Hmmm version 3, always and always;)

Personally, I am the MIT Scratch interface that has evolved. So, I am in version 5.0 with mLink. To answer, Makeblock will be better placed than me, but mLonk is not necessary. Put the Firmware and try the code in upload … Does it work?

Example: Go forward for 2 seconds


#7

Hello StenvneT, please be noted that we will no longer provide any update or support for mBlock 3 soon, and you are highly suggested to use with our latest mBlock 5, and here’s the download link for the latest version: https://mblock.makeblock.com/en-us/download/

With mBlock 5, if you can connect mBot and upload programs into it, the connection should be OK. After the connection, please update the firmware to the latest, no matter it’s factory firmware(three default modes included) or online firmware(used for live mode). If you have met any trouble uploading programs in mBlock 5 after the firmware update, please take a video of the whole progress, and then send to support@makeblock.com , we will open a ticket for your email so that we can follow up until your problem is solved.