Installing Makeblock Library troubles


I tried to install the Makeblock Library zip file that I downloaded from GitHub following the instructions given on the website. I receive the error message: “The library “Makeblock-Library-Master” cannot be used. Library names must contain only basic letters and numbers. (ASCII only and no spaces, and it cannot start with a number.”
This is my first time installing a library and it may be my fault somehow but I don’t know where to go from here.

Any ideas?


Hi - Change the name of the folder then open it again — I changed mine from “Makeblock-Library-Master” to “Makeblock” – close the IDE then nav to and open the demo sketch.


Thanks for your reply…I renamed the zip file as you suggested and still receive the same error message when I tried to install it.


You don’t need to rename the zip file.

You must uncompress it, and then rename the uncompressed folder to “makeblock”

See that picture:

If you still have problems you can download this modified ZIP file of the libraries so you can uncompress it directly without any modification



Thank you JoseCarlos…I tried your method and it appears to be in the right place now.
Here is my Arduino file in Win Explorer

Is this how the library should show up in the Arduino IDE? If so, then I am OK.
Thank you,


Try first to open and compile a Makeblock sample now.

From your Arduino IDE
File -> Samples -> Makeblock ->Me_MotorDriver

If it works you are in the right place to develop any Makeblock robot :wink:


I have tried all the suggestions and still no luck. Anyone have any advice.



Thank you again JoseCarlos…I did as you said and the sample Me_MotorDriver did compile. I will finish building my robot in the next 2 days and try to run the sketch. I still have a question or two but will wait until my robot is completed.
Thank you very much for your assistance!


@toenee60 Looking forward your completed robot, share with us, Tony :slight_smile:


Thank you Jose, you’re just like one of our Makeblcok family member .