I can't upload my extension to mblock extension center


Hi, I have my extension that works fine in mblock3. I wanted to upload it to mblock extension center. But I get the “required field extensionName in s2e file cannot be empty” error despite of my s2e file is valid JSON file. Can you help me?


I have the same problem. I hope they fix the problem:(


@tech_support @bigeyex


I’m having the same problem:

  • mBlock 3.4.12 accepts the extension if I upload it via .zip file
  • I have checked that the .s2e file is valid JSON

But when trying to upload it to https://www.mblock.cc/extensions/index.php I get the “required field extensionName in s2e file cannot be empty.”

Is the server down again?



Hi eduran , dnzayan, roboteach-es

Sorry for the delay. I have provided feedback of this problem. Our engineer will restart the server, please try it later and see if it fixed.


I’ve tried a couple of times already, still no luck :cry:

Just in case, I leave my extension here:
Input-PullUP.zip (2.5 KB)


I have the same problem :frowning: . (since 4 days)


Our problem still continues. Please take a hand in this situation.


Hi @tech_support,

Any idea of when would be this solved?



Hi Guys,

Sorry that our engineers had met some problem to solve the problem before. Now ,it should be fixed, please kindly try againa and feedback. Thanks!


hello again @tech_support,

still not working. Is there a way that your engineers could upload our extensions themselves? Or at least, use them for testing the system?

Kind regards


I just uploaded my extension successfully. There was no problem. Thanks.:grinning:


Yeah, for me too.

I discovered an issue with UTF-8 files with BOM --> UTF-8 issue


I have same problem still


Here is a guidance for you.

Please check and try again.


I’ve tried. I have tried to install the plugin I installed before. (Makers Dükkan Arduino Robot Kontrol 1.0)


Do you mean this extension?
It is uploaded succeed.


I want to install another plugin. But it doesn’t load. I wanted to change the name of the plugin I installed (Makers Dükkan Arduino Robot Control) and it was not installed.


Hi CeyhanMesut,
Is there any error message comes?
Please kindly contact me to support@makeblock.com


how do i get to “manage extensions”?