Help for new mBot user, please


Hello, my son and I completed the assembly of our mBot, powered it on, and tried to control it manually. It seems that the mBot does not respond to any inputs from the remote. The chimes ring a few times and then the front LEDs switch to red. At that point, no inputs to the mBot perform any function. Nothing from the remote and nothing from the mode switch button on the front of the circuit board.

I reinstalled the factory firmware using Makeblock. That didn’t work. I tried uploading two later versions of firmware available from the web. Those didn’t work. I reinstalled the factory firmware. Still no response. It almost seems like the board itself is faulty or corrupt. Am I missing something?

Any help would be appreciated. Thanks.

Here’s a video showing the behavior.


Hi justonwo,

I believe Makeblock will be found quickly with your video. However, I would have liked to wait for the noise when opening the robot. I wouldn’t know what Firmware you are using.

The blinking blue light is strange.


Here’s the video of the mBot from startup.

Here’s a photo of the firmware.

The strangest thing of all, I just discovered. If the USB cord is connected to the mBot, it will work properly. As soon as I unplug the USB cord it stops working.


Hi justonwo,

You have the correct Firmware … and the USB seems to be working.
I recommend that you remove the communication mobule (Bluetooth or 2.4G). Then try again …

If this works, replace the module and test again.


I removed the Bluetooth module from the board. There is no change in behavior.



On the video, it doesn’t seem to be super functional. I believe that Makeblock will be able to identify the problem and correct or replace it …

I leave Makeblock, since Monday is coming and it only works the week.


Hi justonwo, by viewing the video you sent, I think it’s most-likely the battery’s issue. If you are using rechargeable battery, connect mBot to an USB port and charge for about two to three hours and try again; if not, please change the battery to ALL brand new batteries. This case usually caused by low voltage and there’s no enough power to motive the motors once unplugged from USB port.


But it’s too simple. Lucky for justonwo because my next solution would have been to jump on it.

I was kidding, the simplest solutions are often the best


Excellent. I discovered with my voltmeter that one of the batteries was dead. Thanks very much, all. It works now!


While I’m here, what is the best place to get some video tutorials on how to use Makeblock to program the mBot. This is for my 9 year old son who has never done any programming of this sort. I have a background in Matlab and LabVIEW.


Hi justonwo,

There are books, otherwise there are resources on Makeblock: Makeblock

However, the tablet application remains the most accessible and progressive

Finally, we are here to answer your questions


For mBot, we have three Apps for mobile devices, they are Makeblock(assemble tutorial and controlling), Mblock Blockly(game-based app teaching new users learn how to use block to program) and mBlock(same software on mobile for users to program). And for new users, I think you can suggest your son to start with Makeblock and Mblock Blocky


Hi. You may find my book ‘mBot and Me’ (the best-ever guide to mBot and programming in mBlock 5) a useful problem-solving resource - you can download this (free) from: 24

Lindsay Rooms


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.