Having trouble getting mBot to power up


#1

Hello, we have a new mBot we just assembled. When we connect the AA batteries and flip the switch to ON the mBot does not power up. When we connect the bot to a computer with USB it powers up as described in the manual. We are using new batteries and tried changing them several times. Is there anything else we can try to get it working? Thanks.


#2

Hello Jimmyvancura, in this case, if you have another mBot, please try to use another battery case and try to locate the problem. If it could be powered by the USB port, then the mainboard should be normal. The most possible reason is that the battery case cable broke. If you don’t have another mBot, please contact the seller directly and ask for a after-sale request.


#3

I have the exact same issue, and I don’t have another mBot to test with.


#4

Jimmy,

I’m not sure what you tried so far but here is what I have experienced so far. We contacted Amazon and got a replacement. I didn’t build the new unit, I only took the battery pack out and attached it to my existing unit that has the same symptoms as yours (Powers under USB but not battery pack). The new battery pack had the same issue, no power. As I was removing the new battery pack it powered on for a brief second, so I played around a little bit and discovered that by squeezing the sides of the battery pack, the unit powered up. Ultimately I got it to power on indefinitely without me squeezing the battery pack by stuffing aluminum foil bits on the positive end of the battery pack terminals. I noticed there are plastic “stoppers” on those sides of the plastic body, I don’t know if removing them would also solve the issue, but the foil seems to do the trick so I am going to leave it at that.

I’m also using regular duracell batteries, maybe other batteries have different dimensions and don’t have connection issues with the battery pack.

I hope this helps.