Hardware extensions on 2 boards not working, other working fine (same code)


#1

I bought a mBot extension kit with fan, temp sensor and fan.
The idea is to create some projects with a small setup with the framework or the mBots driving around.

At home, I have 4 mBots:

  • 2 full kits (board, framework, motors, wheels, …)
  • 2 boards-only

The attached code works file on the 2 full mBots, but not on any of the boards-only.
All boards were upgraded to the latest firmware.
I tried restarting, on/of, relaunching software, …

On the board-only setup, in the best case the fan moves just 1 millimeter.
The other sensors do not work.

Any idea why this isn’t working on the boards-only setup?
How can I see if there are different versions of the boards?

Thanks!


#2

Nobody has an idea?
mBlock sales/hardware support? @tech_support


#3

I don’t think there’s functionally any difference between V1 and V1.1 boards.

Have you tried the sensor and fan in other ports? Are you powering the boards-only setup with powersupply or battery pack, or just through USB?

If you want to get in touch with support, I find emailing them a better approach as I haven’t seen them on the forums in a while (even before Coronavirus hit…)


#4

Adding also the battery solved the issue, many thanks, Elliot.