Halocode is not updating



I connected the Halocode to my computer. But i can not upload any code to Halocode. I tried to updated it and it always stuck at 20%.

+when i try to upload the code i got this error:

Do you have any idea why it’s like this?


Hi gungorhilal,

I tested, there is no problem for the upload. Did you try a simple code:

Me, I use mLink 2 with the web version under Win10


Mine is not working. I tried with web version too but still it’s same. It’s stopped updating at 20% again.


I’ve had this happen to me. It seems like it goes back to normal within the time it takes to make an angry message to tech support. I think it’s something with the Makeblock network updating, like a full moon.


I need to do some projects so idon’t wanna wait for it:)

I’m just wondering how can i understand if my halocode is broken but it seams working with the blue light on it. Do you have any recommendation for me to update the halocode succesfully? @tech_support


you are so right! after 4 hours it started working suddenly! thank you so much:) @ProfessorHu


Capricious the beast :wink: