Getting Started With Codey (detection and BT issues)


Hello Every one

i just received my codey rockey and i have issues to connect it to my P.C., I have my BT from Makeblock

when i connect the BT or Directly the Codey Rockey the following is shown

but wht i click connect in my mblock software it doesn’t detect the codey

i had searched for the drivers, but the drivers that come with mblock are not signed so windows doesn’t allow me to install them, and the generic drivers for arduino doesnt solve the problem

could any please help me to see what im doing wrong?

My son is crazy to start with Codey

P.D. the app doesn’t let me run the code section, i just can drive


I found the right drivers on the github page:


Thanks @JurgenG but for Windows is not working, they need to be signed as far as i know (and windows tells)

if you have a knowhow of make it work i will be glad to read it


Would you please tell me what is a BT?

Seemingly you already have the Driver installed, otherwise CH340 should not show up in the Device Manager.
Try re-install mBlock, connect your Codey with the USB Cable, make sure you have turned the power on by pressing the power button once (the light near the power button is blue), then try to connect again.


Dear @bigeyex
I have reinstall the m block and used the cable to connect the codey already turned on, but still is showing the message that the driver is not ready.
BT stands for Bluetooth, Wich is the dongle I buy.


Hi Lobogalvez,

How about trying remove the Bluetooth dongle and just connect the USB cable between Codey Rocky and computer have a check?

Besides, please make sure the codey rocky is not connected to any mobile device at the same time.


Thanks but I had tried wired and wireless but the error is the same the device driver is not ready


Hi Lobogalvez,

From the picture, there are com ports corresponding to CH340 under the computer’s device manager, it looks like the driver has been installed but it may be prevented by any security software on the computer since it shows not enabled. During the process of re installing the mBlock software, Did any message pop up to prevent something? Could you try check the security settings on this computer?

Besides, what is the operating system of your computer? Do you have any other computer have a check? If no other computer, please try change the USB port on computer.


Please also check if you disabled the driver under its properties page? If yes, please try if you can enable it from here have a try.



i have follow these steps

  • uninstall and erase any folder of mblock
  • uninstall drivers of codey
  • turn off any protection software
  • install the mblock with admin credentials
  • connect codey with cable once the mblock is installed and has started
  • install drivers of codey
  • the issue remain
  • install the bluetooth dongle and try the previous steps
  • the problem remains

my system specs are

this is the error

These are the events of the driver

Information 5/7/2018 11:41:42 AM UserPnp 20001 (7005)
Information 5/7/2018 11:41:42 AM UserPnp 20003 (7005)
Information 5/7/2018 11:41:42 AM UserPnp 20003 (7005)
Information 5/7/2018 11:41:42 AM Kernel-PnP 440 None
Information 5/7/2018 11:41:41 AM Kernel-PnP 430 None

This is the only error i got about com distribution
The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
to the user WEREWOLF\ekis_ SID (S-1-5-21-3404449279-3901438767-3374080523-1001) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.


Hi Lobogalvez,

I have sent a message to you with a special file, please check if you receive it and let me know if it works.


I am having exactly the same issue with a wired connection to my Codey - tried on three computers - all running Windows 10. I get the USB-SERIAL CH340 (COM4) in device manager but when I try to connect to it in mblock 5 it says the device driver is not enabled with a similar set of events.

I have followed a very simialr set of steps as in Lobopglavez last post on both desktop at home and dekstop at work.


Hi Lobogalvez,
We would like to offer remote control for you, and our service time is from 9:00 to 18:30, Monday to Friday, UTC+8. Please reply when we can remote your PC with you.


I have Found the Damn Error
ok i got my mblock installed in a drive different that my OS, i have more space in D: and i limit my installations in C:, i just awake in the middle of the night thinking in that if the runner of the service is not finding the relative path for the OS si because its searching from the drive where is installed, today i just try this change and it works T.T to simple and obvious that i didn’t see it, Thanks for the support of all enjoy your Codey Rocky, we will do it xD


I had a similar revelation today - tried letting it install to default location - and now it happily works on home desktop. Came about because it worked on laptop earlier where it was installed to default location… Hap[pil;y playing now…


Hi gilreth & Lobogalvez,
Glad to hear that it fixed now. And many thanks for your sharing.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.