Firmware update fails on 20%


#1

Hi,
I’ve got the ranger for my son as a Birthday gift, sadly enough after assembling it with the big rubber wheels it didn’t move.

I’ve removed them and tried, it was working, the back wheels was spinning, this didn’t last for a longer time :frowning:

So it did stop completely and with any command, it just makes the beep sound and nothing else.

After searching many topics, all suggested firmware update, so I’ve connected it to my PC and did the update, which will start and continue to 20% then fails :frowning:

With the following error

I’ve tried many times, and did restart also, but no luck :frowning:

Any advice, please?


#2

Hi Samy, according to your description, I think there are three points that possibly went wrong:

  1. With caterpillar tracks the motors are not working, but without caterpillar tracks they work fine
    ----------This could be caused by the wrong installation, you might choose the wrong hole to put in the screw so the caterpillar tracks is too tight and the motors will not be able to motive it. Or it could be caused by low battery.

  2. It stoped moving and just made beep sound
    ----------Maybe with beep and sound together? Similar situation often happens when the voltage of the battery is too low. Please change to ALL brand new batteries and try again. Note that mix of used and new batteries will not work.

  3. Update firmware failure:
    ----------Two main reasons. First one is that the CH340 driver is not installed properly. Please download and install, restart your computer and try again. Download link:
    http://www.wch.cn/download/CH341SER_EXE.html (for Windows)
    http://www.wch.cn/download/CH341SER_MAC_ZIP.html (for Mac)
    You can also check this link for more details: https://www.mblock.cc/doc/en/faq/ch340-driver.html

Second reason is that the date transfer went wrong. Please try with another USB port, another USB cable(if you have), or another computer.

With steps above, I think your problem can be solved. If you need any further assist, please contact at support@makeblock.com . We will help you via email.


#3

Hi Samy

Try turning off anything else (like a printer) connected via USB.