Error with Upload and Firmware update


With mBlock5 I cannot update firmware nor upload programs. With mBlock3 at least the firmware update works. I already read several posts about this topic and the mBot Ranger extension is loaded and I have installed mLink.


I am new to Mbot but I have updated by firmware from windows 10.

It can only be done via USB connection in upload mode.

If using windows have you installed the ch340 driver?

When plugging in the Mbot does windows make a npise letting you know a new device just got connected??


I have unistalled and installed the drivers, but that does not solve the problem. Yes Windows makes the sound when I connect the serial port.
Thanks for your idea, it was worth a try!


Have you selected Mbot ranger as the pc software automatically tries to connect to a codey not rnager??

Can you successfully connect to the mobt??


Yes the Ranger connects:


Switch to upload mode before trying to update


Hi Bardo,
May I know the operating system of your computer?
Please install mBlock5 software into your computer and try again.
If you failed when using the web version.
Here is the download link for you.


I am running Win10 with newest updates.
I already had it installed on my harddrive.
Now I also tried the web-version of mBlock5, which produces the same error. I also tried to unistall and reinstall the software (using the link above), but nothing changed.
Maybe an additional desciption: The firmware update starts and sometimes there is even a progress button, but it has never reached more than 40% before it stops.


Hi Bardo,
I send you a test version.
Please download and try.


This test version worsk!
Thanks a lot.


Hi there,

can you help me as well? I have the very same issue: new codey rock arrived yesterday. Does connect (via browser and via mblock5 application), I can upload simple routines but nothing happens on the codey. Tried to update firmware as recommended by the application but it always (both via browser and via mblock5 application) when it reaches 20%…

Any suggestion before returning the Codey to Amazon?




forgot to mention that upload looks like it works as the codey blink the blue led after upload (it works both via bluetooth dongle and usb cable)


Sorry to everybody, not sure how but I managed to upgrade the firmware and now it looks working anc correctly executing the routines… thanks


Same situation here: I’m not able to update / reset my firmware for the mBot Ranger by using mBlock 5. Neither I can upload other code in Arduino mode.
When trying an update, it stops after giving a beep at different stages (from 3% to 42%) and gives me an error.
I’m using mBlock 5 for Mac, but same behavior for Windows 10 (works in a Parallels VM). Tried using mBlock 5 for Mac, Win, and the browser based app with installed Win drivers. No chance.
After the failed attempt for the update, I’m not able to use live mode again for programming with mBlock, so I do have to reset the Auriga Board. No way to do this with mBlock 5.
But I discovered a workaround: mBlock 3 for Windows is still doing the job for me in my virtual Win 10 machine, i.e. it works when i try to reset to the default program. Unfortunately, mBlock 3 doesn’t work in my macOS 10.15.4 Catalina, due to it’s a 32bit application.
So please help if there is another version which avoids these struggles. My workflow so far is very complicated: Testing code with mBlock 5 in live mode. After that, copying the code into the Arduino IDE, upload it to the Auriga / Arduino board. After that when I’ve still to do some testing, I do a reset again with mBlock 3. Very annoying.
BTW: I’m an editor. I use mBlock as a very powerful demonstration system for a new update of my book dealing with most topics of modern computer science. It’s the best system I know so far for STEM.


Sounds complicated :frowning:

It is definitely a coms problem as you know the Auriga works with mbock3 in windows VM.

I can confirm that I have no problem uploading to a Auriga with mblovk5 on my windows 10 machine

I always find running a OS in a VM never works quite the same as running the OS directly on bootup. There is often problems just as you describe. I have a windows 10 machine but some robotics tools that I iuse for my other robotics projects are only available on linux so I tried running linux in a VM on my windows machine and often had problems like you describe so ended up just getting an old PC and loading Linux on it so now I don’t have problems.

I think you problem is that your software is having trouble talking to the CH340 on the auriga. I suspect that the MAC OS is blocking it for some reason, either not setup right or firewall blocking it


Hi rhatt,
I send you the test version of mBlock5 too.
It is only for windows, you can install it to your win 10 computer and have a try.


Thank you very much, works like a charm! Looking forward to see this version for the public, too, maybe also an adapted version for macOS? Thank you anyway…


Hi rhatt,
You are welcome.
We will release the new version as soon as possible.
By the way, only windows users has the same problem and it happened randomly.
Hope you can understand.


I am also having a problem with my mBot Ranger where the upload always fails.
The furthest I have seen it get is 15%.
I am using mBlock 5.2.0 in Windows 10.

Is it possible this new version may work for me?



Hi bennyattack,
Please download the test version and try again, I have send it to you.