Cyberpi stuck in firmware update loop


#1

Dear forum,
today I tried to update the firmware of the CyberPi belonging to my mBot2.
First I connected the mBot2 to the mBlock V5.4.3 running on a Windows PC. Connection was established via USB-C, I could execute commands / upload programs. From settings in the mBlock Software I selected Firmware update. This ended in a boot loop of the CyberPi. However I could break the loop by turning the CyberPi off and on again.
So I configured Wifi and selected “Firmware update” in the CyberPi Menu. Now, when I switch it on, I see on the CyberPi screen the logo “cyberpi”, a progress bar that is not moving, and “Connecting…”. After maybe half a minute, it switches to “Updating…”, and then after a few seconds to “Fail to connect”. If I push a button, the process starts again, with the same result.
Neither pressing any buttons nor restarting the cyberpi lets me escape the loop.
The mBlock software still says it is connected to the CyberPi, however I cannot upload any programs, and I cannot execute live commands.

What can I do to restore the cyberpi?

My problem seems to be similar to Cyperpi stuck in firmware update screen. Continous loop, which seems not to have been resolved.

Thank you for your help!


#2

@irkenzim This is concerning. :confused: As stated in other posts, make sure you don’t have any kind of kid-safe DNS filter or firewall that might be blocking a connection to the firmware update API. Also try the web version at
https://ide.mblock.cc/
and let me know your results. I’ll try to test with my mBot Neo later. Good luck!


#3

Dear Best_codes,
thank you very much for your answer!
I checked the router, and yes, there was a kid-safe filter. I deactivated it, but the situation did not change. I turn on the mBot2, and it still loops as described above. The router registers a device “espressif” that connects to the wifi for a short moment, I guess this is the CyberPi.

I tried the web version as you mentioned (and installed mLink2). It had the same behavior as the desktop client. However I think neither the desktop client nor the web client can really communicate with the cyberpi at this point, as it is stuck in the update loop that is probably working outside of the cyberpi software.

Best regards, Zim


#4

@irkenzim If you think the cyberpi is stuck in an update loop, remove power from it! But, be careful in doing so. I guess I’ll have to run some tests on my mBot later…