CyberPi not available mblock 5.1



I want to use mBots2 in my classroom. We use Intune to deploy software to our students’ notebooks. Currently, it seems that per default only mBlock 5.1.0 is available in Intune.
After deploying it I open mBlock BUT in the device list, CyberPI is not available. Do I need a later version of mBlock?



I do not have any problems.
However, you can try the web version at

Thanks for your time,


Good to know you haven’t got any issues.
I deployed version 5.4.0 and run into the same problem: NO CyberPI available. What? Why?
Can I add it manually?

I’d prefer the desktop app over the webversion.


What OS are you using? (Windows, macOS, Ubuntu, etc.) and have you closed and reopened mBlock 5 recently?


Hello Best_codes,

at school, we use Windows 10 and 11. As I mentioned, I deploy mBlock with Microsoft Intune and for some reason I do not comprehend, CyberPI ist just not available.


You deploy it using Microsoft Intune?
Can you deploy it directly from your device instead?


Same problem here. mBlock 5.4 on windows, installed via Microsoft store. I connect Mbot neo, switch it on, start mblock, Click add device, the entire library appears, but cyberPi is not there. Checked using device Manager, mBot is connected (ch340 on COM3).
Restarted mblock and repeated process several times, still does not work.
Also, the connect feature in mblock does not detect the mbot neo


Made some progress of sorts, but still no solution.

Installing via Microsoft store installs version 5.1.0, without possibility of upgrading. I deinstalled , and installed 5.4.0 by downloading install file from the makeblock website.

I now get a much bigger device Library, but still no CyberPi.

There is a "CyberPi for Chrome, will this also work with the installed mBlock app?

Why is CyberPi not showing in the Device Library?


Any way to “manually” install CyberPi device?


@cguide @Neko

Based on the new info and some research, I discovered that mBlock hasn’t updated mBlock on the MS store, but they have on their website. You can see it on their site here:

I have tested this multiple times with no issues.

Yes, there is. Since you both seem to be having issues with the software that I can’t really fix, I will message you a download link with instructions for adding cyberpi manually.


Hello Best_Codes,
your fix has worked, thank you!



@Neko, I’m afraid I missed out on sth. What was the solution?



@cguide I messaged you with it. I’ll mention you again.