Connecting mBlock 5 to Arduino Uno using USB


I am trying to connect to Arduino using USB on mblock 5, however the connection widget keeps spinning and cannot enumerate the COM port on which the Uno is connected?

Did anyone succeed in using Arduino on mBlock 5?


Is it Arduino Uno board from Arduino official?
Can it be connected in mBlock 3 or Arduino IDE?
Any other device tested in mBlock 5 and worked?
How about checking “show all devices…” option?


Yes, Arudion does work with mBlock 3 and arduino IDE as well. I missed that information.
I did check the show all devices as well, none was detected. I have not yet tested with mBot.
Will do that and post the results here.


I tried to test it on my mBot, but unfortunately the mBot itself stopped working even with mBlock 3. It’s been time I used it so not sure if my drivers have gone bad (should not be the case) or hardware has gone bad.

In any case, I am not in position to give you more inputs on this, except that the mBlock 3 detects the Arduino board, but mBlock 5 does not.

By the way do I need to have mLink running? I am not sure and hence wanted to confirm.
This sounds like stupid, but I think it need not be running, as the I am running off the desktop software.



Hi msapariya,
I have send you an email with attachment, please check it.


Checked it again. mBot connects with mBlock 3, but not mBlock 5.


Hi msapariya,
Sorry for the delay. Is the issue solved?
Have you ever tried to reinstall mBlock 5?


in the mBlock 5.1-download for Windows I got for our school’s laptops there was no Arduino Uno or Mega included in the extension center as was in the Mac-download. Can this be added somehow? Maybe there already is a link or an instruction in the forum?


Sorry, you mean in the device library, there is no Arduino uno?

You may give me a screen shot?