Compiling GiyHub 3.4.5 release / No Serial Ports


The mBlock 3.4.5 source code has been released now on GitHub (currently as s branch off the main one). I got the source code compiled with no errors, but it cannot connect to the mBot or Arduino on the serial port. Under “Connect / Serial Port“, it is just blank, no serial ports show up. The Arduino IDE can see the boards, and the released mBlock 3.4.5 software (from mBlock website) can see the boards. Only the compiled source code of mBlock here cannot see the serial ports.
I compiled the source code with the instructions here:

I examined the compiled-exported GITHUB mBlock with a released version downloaded directly from mBlock website and found the following folders were missing from the compiled-exported version:
• /arduino folder
• /drivers/ch341 folder
• /drivers/usbserial folder
I put those three directories back into the mBlock folder of the complied-exported version and ran the program again, but still no luck. The compiled-exported mBlock version still cannot see the boards on the serial ports.
Can you explain how to get the compiled version of mBlock 3.4.5 to see the serial ports? I think the solution has something to do with those 3 folders missing frim the GitHUB release, but can’t figure out how to connect them in.


Got it 90% solved now. The key is the use the _win versions when installing the ANE files into flashbuilder. Then copy in the arduino, ch341, and usbserial drivers into the completed MBlock directory.
Now can connect, upload firmware, and “upload to arduino” , only “edit with Arduino” button still not working.