Colour sensor doesn’t work; cannot connect to Wifi; Rocky doesn’t move


#1

We got Codey Rocky as X’ams present for my older daughter.
However I discovered the color sensor doesn’t work.
I tried to calibrate it, and it shows “failed” every time I try.
So far, our codey hasn’t been able to connect to our Wifi yet. All the other devices at home are working fine.
I use mBlock 5 to program Codey Rocky to move around but it doesn’t move.

It would be great if anyone can help me figure out how to get Codey Rocky work. Thanks.


#2

Hi Ginger,

Let’s start our research with 4 small steps:

  1. Recharge the Codey Rocky battery and try the default behavior. Button C = Fear, Button A or B = Happy. Be careful, it can get shocked if you press too often.

  2. Install mLink2 on PC, MAC or Linux (Do you have a computer?)

  3. Then, are you able to upload the latest Firmware. Try with a USB cable and not with the USB dongle? Are you on PC, MAC or Linux?

  4. Are you able to connect with a makeblock application on IOS or Android tablet? (in Bluetooth)

Then, I will continue the steps …


#3

Hi Crackel,

Thank you for your reply.
1, Initially, I downloaded the apps on my iPhone 6s. It’s easies for my daughters to control Codey Rocky using the app while I was busy in the kitchen. Codey Rocky worked fine with the makeblock app: drive, draw and run.
2, I have installed mLink2 on my laptop with windows 10 system. Since I found the color sensor doesn’t work, nor Codey could connect to the Internet. I uninstalled mLink2 and installed mBlock 5. However, this didn’t solve my problem.
3, The firmware was able to be uploaded. I was using the USB cable the whole time. I have the USB dongle as well, Codey could make the sound indicates pair successfully but the software shows not.
4, Codey Rocky could be connected with my iPhone vis bluetooth.
5, We used the mBlock app on my phone to take the “Codey Basic” learning game. The funny thing was, the app thought Codey Rocky moved … but actually, Codey Rocky didn’t move at all. Codey could make sound, show stuff on the screen, sense the light, show different color of lights.

Thank you.


#4

Hmmmm…

Try to take mBlock under IOS and do the following code:
s


#5

Thank you for your help.
I tried your code but Codey Rocky didn’t move for me. :pensive:


#6

Hello,

I have to leave the relay to Makeblock. You can always make a little video to show off your robot.

When Mokeblock finds a solution, let me know …

Thank you


#7

Hello Ginger, the firmware can only be updated via USB cable, but programs can be uploaded via Bluetooth dongle. Note that if you pair Codey Rocky with the Bluetooth dongle, you will need to select USB connection in mBlock 5 desktop on your computer, rather than the Bluetooth connection. For the fact that Codey is not responding to the program, please try it on the desktop and shoot a video send to support@makeblock.com . We will help you solve it via email.


#8

Thank you for your reply.
I have talked to the Makeblock’s tech support in China. I have tried all the things for troubleshooting they asked me to do. It took nearly 6 hours. The solution is that Rocky has problem. Now I’m suggested to contact the distributer directly to swap it or something. I sent email to the distributer this morning, and now I’m waiting for the distributer to get back to me.


#9

If it’s located to be a hardware problem, you will need to talk to the seller where you buy it from and ask for an after-sale request(usually the warranty is within a year). We authorized our distributor to provide after-sale services and usually we will send them replacement with their orders


#10

@Ginger this sounds like a problem with Codey’s connection to Rocky (the drive unit, and where lights and sensors are).
There is a connection that’s made between the two, and it could have some debris in the way? Try checking it on both Codey and Rocky. Look for 4 gold contacts on Codey and pins on Rocky. The little pins (called Pogo Pins) are spring loaded and can be checked with a toothpick. Press them in, and they should return.
There are also magnets built in and they could pick up something like a staple or small metal piece. this could keep the contacts from touching properly.
If it is controllable (Codey drives) from your iPhone still, then it’s not likely the problem.