Cody rocky connection


just got my cody rocky robot.
looks great.
i have difficulty to connect it to my mac.
can’t find it via bluetooth nor USB , what os the problem ?


Hi rami.shaked17h,

To your issue, that is the serials driver of the CodeyRocky prevented by the Mac system.
Please go to “system preferences”-“security&privacy” to allow it.
Enclosed is a screenshot for you.

For the Bluetooth connection to PC, it needs the makeblockBluetooth dongle.

Connection issue

Thanks, unfortunately i didn’t purchased the makeblock bluetooth dongle, can i use alternatives bluetooth dongles ?


My system security is exactly as in the screenshot but still can’t connect to the device.
it doesn’t recognized it on Com3 like in my win7.


you can use any BT in your phone or tablet.
I combined codey with ipad and xiaomi Redmi note 4 pro with no problem. I think I can connect as well with the laptop


Hi rami.shaked & Kyniolus7312h,

On mobile device, it can connects without the makeblock dongle. But on PCs, it can only connect with Makeblocl Bluetooth dongle.

@rami.shaked, for the serial port issue, on mac computer, the serial port doesn’t list as COMXX, it should be similar to /dev/tty.wchusbserial1410
Besides, please make sure you have restart the Mac after you allowed it.


solved: I had installed specific driver for the mac os from here

please put links for driver at your product specification, it’s would be helpful for our users


Hi rami.shaked21m,

Glad to hear that and thanks for your suggestion.
Do you use the latest version mBlock 5 software. Normally, it install the CH340 driver together automatically during its installation.
If there is the case that need manual install the arduino driver, we will add the driver download link in the making FAQs for the Codey Rocky.


Hi rami.shaked7d, everyone!

I was experiencing the same USB driver issue but on windows 10. I installed the latest mBlock 5 when i received my Codey Rockey, however the USB driver was unrecognised (I also tried removing it and reinstalling different versions).

rami.shaked7d the link you provided above has downloads for the windows drivers that worked for me right away! link to windows drivers.

However i also found that the Makeblock Github Makeblock-USB-Driver repo also contains the same drivers in the wch341 folder.

I think that these instructions should be added the the FAQ section about mBlock 5 as i was unable to use the Codey Rocky till this morning!

Anyway its working well now thanks!



Hi all, I am also encountering an issue with USB connection to makeblock 5. I am on a mac with High Sierra. Is this a mac issue? – after downloading Makeblock-USB-Driver from github it works - thanks!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.