Codey Rocky, coding issue


#1

Hi, i have Codey Rocky and problem with sending code from my laptop to Codey… when I send code, he s acting dead… nothing happend… whats wrong?
I ll try with my phone, same thing…
Actually I have even problem with mblock app, Events (tutorial)… it says
Run the program. When button A is pressed, Codey will play the sound meow… and nothing again…
Help please


#2

Hello KatjaB,

We will start by looking at the computer side. Here are some questions to get started:

PC / MAC / LINUX ???
OS / Version ???
Bancher in USB or with the Dongle ??
mBlock 5 or online: https://ide.mblock.cc/ ???
If online: Have you installed the mLink ???

Is it functional in Live?
1

Is it functional in Uplaod?
2

Finally, is there an error message ??


#3

Windows
USB, tried on both way:mblock and online.
mLink installed.
And there is no any error message.
Before, when we turn on Codey, he had eyes and blinked…
Now, we have empty screen.
He react just if control him im drive mode


#4

Hi KatjaB,

When you upload Firmware, your robot should work. Eyes, buttons, and other default functionality. Does this first step work?

Then, is it the following 2 instructions in upload and graphic mode. If it doesn’t work then go to live mode.

I already had a black screen when there was an instruction in error. With a simple program, you shouldn’t have a black screen.


#5

Hi KatjaB,

Sorry for the delay. For the problem you described, please upgrade the latest firmware for codey rocky with mBlock 5 software as Crackel suggested. Hope that you have already solved the problem.