Codey doesn't interact


I have purchased a codey rocky.
The battery is full (when charged the green LED is on).
The Iphone and the Macbook can see Codey via Bluetooth.
Codes seem to be transferred via Bluetooth (the computer informs about 100% completion and Codey blincks on the screen)

But the problems begin here.

Not a single command is executed.

I tried with the simplest :

  • When button A (B,C) is pressed
  • move forward …

I can press whatever I want - nothing happens.
The same is when i change “press button” to “shake codey” or any other event.
I thought - maybe the motor is broken.
So I changed the command into “show picture” on the screen.
But still nothing happens.
I tried with Iphone and Macbook - nothing happens.

Please help!

PS When switching on codey the display is also dead.
The only LED working is the one to acqnowledge the data transmission.


Hi zstaszewski,

Try with the Makeblock app on your iPhone and select DRIVE. Is the remote control functionality working well. Be careful, you have to select the right material: Codey Rocky.

Next we will look at the mBlock application


Thank you!
It works when using the makeblock app.

However the coding is still not working :frowning:


Bummer @zstaszewski ! Factory reset maybe? When turned on initially there is an active program - or after factory reset. Pushing buttons should make him react with faces access noises.

How to:
After the software and the device are connected to each other, select the device window below the Stage Area, then click the Settings button in the top right corner of the device field before selecting Restore to Factory Settings.


I have updated the firmware on the codey and it works now!
Thank you for your help.


It works now!


Great news! Enjoy!!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.