Chromebook will not upload code to mbot over USB


#1

I cannot upload code to mbot over USB from chromebook.
It works on PC and Mac but not from chromebook

I need to program the mbot, disconnect it from the chromebook and have it run on it’s own.

I found, one other user with the same problem but they did not get an answer.

Here what he said:

Please help. Just bought 14 mBots. 1 per student for coding in this new Covid-19 environment. Each student has a chromebook at their disposal. Was hoping it was a perfect solution. Here is my problem:

Finished the build today and connected the mbot to Chromebook via usb. Installed the mlink extension and was able to connect to the mbot through the ide.mblock.com 1 interface. I made a short program:
When mbot(mcore) starts up
move forward at power 50% for 1 sec

Switched to upload mode. Tried to upload and the upload fails telling me to check the logic in my program.

Switched to LIVE mode and changed the starting event to “when onboard button is pressed” and the robot follows the program perfectly.

Tethered robots will NOT work for class. PLEASE HELP!

I updated firmware to 06.01.107
I’ve also downgraded to factory (06.01.009) and tried the above with the same results.

I have the same problem. Tried it on different chromebooks still does not work.

Does it work on Chromebooks?
How do you do it?

Thank you


#2

If you use website mBlock in chromebook,then you need to install mlink to your chromebook,and by enter mlink to use website mBlock to try again.


#3

I did that at the start. I installed mlink.
It gives me an error when I upload to the mbot

Have anyone been successful uploading to a mbot over usb from a chromebook?


#4

Ok everyone here is what I discovered.
I have been successfully uploading code from a chromebook over USB to mBot
Here is a summary of what I did

  1. When to mblock.makeblock.com/en-us and clicked on Downloads
  2. Downloaded mLink for Chromebook
    3.Clicked on the Devices tap on the left side of the app and then clicked on(+ add) Wait a few moments
  3. Select mBot
  4. connect your mBot to the chromebook with the usb cable and turn on the mBot
  5. on the app, click on Connect and Select Show all connectable devices and click Connect.
  6. On the app click Update then update Firmware
  7. Turn of the mBot and Chromebook. Wait a few moments, restate and repeat steps 3-6
    9.Select upload on the left side, create an program, Use when mBot start as your first brink
    *****Grayed out brinks do not work in Upload
  8. Click on the upload with the arrow and wait for the program to upload.
    *** It will start to perform with the usb still connected.
  9. Disconnect the mbot from the chromebook and press the reset button on the mBot
    It should perform the code
    This works for me. I tried it on 3 chromebooks

Good Luck