Cannot install mlink for Raspberry Pi Computers


#1

Hi Makeblock . I am a STEM tutor and I admire the simplicity to teach coding using Mbot.

Recently our lab setup was updated to Raspberry Pi Computers as it is more Student friendly . Unfortunately we are not able to install either the mblock5 or use the web version by installing mlink.

Installing the deb file displays architecture not compatible error. I tested with ubuntu and it works fine

How can we resolve this .


#2

Raspberry Pi Computers is using arm architecture,the needed driver CH340 for connecting MakeBlock products cannot compatible with arm architecture.

Once you install mBlock softeware to the computer,it will install CH340 driver automatically,that’s your computer occurred compatible error.